I'm trying to install Debian 8.1 64bit on a Toshiba Chromebook cb30 from USB. I previously had successfully installed the 32bit version on the same laptop (32bit by accident... hence the reinstall).

However the installer reboots the laptop whenever I select 'Install', 'Graphical Install', 'Expert install', etc.

The Chromebook processor according to uname -a is x86_64 Intel Celeron 2955U.

The steps I took to get to the current point were:

  • Enabled developer mode in Chrome OS
  • Ran crossystem dev_boot_usb=1 dev_boot_legacy=1 in a shell in Chrome OS
  • I created a bootable USB in my existing desktop Debian by:

sudo dd if=/path/to/iso/debian-8.1.0-amd64-lxde-CD-1.iso of=/dev/sdd bs=4M; sync;

I also tried using unetbootin, different USB sticks, CrunchBang++ ISO, Debian netinstall ISO.... same lack of success... Interestingly, ArchBang works from USB, though I'm still learning Debian, so perhaps it is a tad too early for me.


In response to the comment asking for why 64bit:

The reason, why I'm trying to use the 64bit version is that, when I installed the 32bit version, I had only access to 1GB of RAM. I searched around and found some proposed fixes, though none of them worked for me. Hence, I decided to try the 64bit version. The 32bit version installed without any issues, so I assumed that the installation would be trivial.

Also I just found out that the same problem has been reported over here

  • I had debian 32bit up and running though for some reason I only could access 1GB of ram. I didn't install archbang however the life usb works just fine, i.e. it fully boots up.
    – pandita
    Aug 23, 2015 at 21:21
  • Could you clarify - in your question - your need of 64bit system on such a device? Aug 24, 2015 at 6:25
  • 1. 32bit systems have up to 3-4GB of RAM support. This more likely sounds, as if your HW would actually have only 1GB of RAM. Could you try live USB of some other distribution (32bit) like Mint or whatever, just to test it? 2. Please post the result of the following: grep --color=always -i PAE /proc/cpuinfo and you can see yourself, in color, if the PAE is activated/available Aug 24, 2015 at 9:08
  • Archbang clearly showed 2GB of ram which is also the official spec for this CB. I just tried Trisqel, which surprisingly works as well considering it is based on debian. Running your command there shows that PAE is activated. I'm downloading a 32bit version of linux mint at the moment and will see how much ram this one gives me. Oh, and Trisqel also shows 2GB of ram....
    – pandita
    Aug 24, 2015 at 11:38
  • @burian - 64-bit OSes don't suffer the register pressures of X86. I know projects that enable PIC for X64, but disable it on X86 because the GOT pointer is placed in EBX.
    – user56041
    Feb 4, 2016 at 1:40

1 Answer 1


Maybe it's a BIOS quirk with some bootloader configurations. Since the ArchBang bootloader works, download the linux and initrd.gz files into it from the 64-bit Debian netboot installer, and manually add a corresponding item to the ArchBang boot menu, or invoke them from the bootloader command line.

  • That's a cool idea. I ended up installing arch as I needed the laptop and it seemed like a general debian bug others had too. Anyway I'll try this next time I'll reset the CB.
    – pandita
    Aug 29, 2015 at 13:49
  • Chrome OS does not use BIOS; rather it uses EFI. Also see Chrome OS Verified Boot. The slide deck also briefly talks about Developer Mode and using different OS images.
    – user56041
    Feb 4, 2016 at 2:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.