0

I am trying to compile GTK+ from source and have installed JHBuild for this purpose. I've already managed to build PyGObject using JHBuild and the sanitycheck runs without output.

For building GTK+ it seems that JHBuild needs GnuTLS >= version 3.0 as it states in the terminal:

checking for GNUTLS... no
configure: error: in `/home/xiaolong/jhbuild/releases/gnome-apps-3.17.90/glib-networking-2.45.1':
configure: error: "Requested 'gnutls >= 3.0' but version of GnuTLS is 2.12.23
You may find new versions of GnuTLS at http://www.gnu.org/software/gnutls/"
See `config.log' for more details
*** Error during phase configure of glib-networking: ########## Error running ./configure --prefix /home/xiaolong/jhbuild/releases/gnome-apps-3.17.90/install --enable-installed-tests --disable-static --disable-gtk-doc --disable-Werror  *** [13/29]

So I searched and found the following instructions on how to build GnuTLS in a more recent version than installed on my system:

http://www.bauer-power.net/2014/06/how-to-install-gnutls-3123-from-source.html

I needed to install some libraries to complete the instructions without errors, but that's done. Now I thought JHBuild would surely run fine until the next error in the build process of GTK+, but that wasn't the case. Instead I still see the same error message about requiring a version >= 3.0 of GnuTLS. It seems JHBuild has a problem locating the GnuTLS build from source and still finds the one installed from the package management system instead.

How do I fix this behavior?

0

I figured it out. I had to uninstall the library libgnutls28, which was previously installed using apt. After that I ran the jhbuild build command again and got other errors, not related to GnuTLS anymore, so I guess they don't fit into this question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.