2

I am running Ubuntu 14.04 inside VMware workstation 11.1. I testing changing the color depth and now I am hitting a login/logout loop. When the login screen comes up I select my account, type in the password and it immediately refreshes the login page.

I was following the instructions Here. I was running these commands as root. Specifically, I did exactly what the answer provided:

Xorg :1 -configure
startx -- :1 -depth 8

I managed to get to a shell prompt as root using recovery mode and ran the command again this time setting it to 24 thinking it was just not able to run 8 bit. However after changing it to 24 it still has the same behavior. So back to the root shell again I go. I tried dpkg --configure xorg and xserver-xorg but both return fatal errors. I then removed the xorg.conf file that xorg -configure creates. No luck. I went into my user home directory and I notice an .xsession-errors file. I open it up an see this:

enter image description here

At this point I am out of ideas to restore the behavior so I can log into accounts. Also, in VMware I notice an error with Unity that says it can't enter unity mode because the guest OS resolution can't be changed. Pretty sure this is the result of what I did. Any suggestions?

  • I was able to figure this out. Since I ran the commands as root, the changes resulted in the .dbus folder and .Xauthority files ownership being changed over to root. Once I chown'd them back to my user, I was able to login again. This was somewhat of an odd problem, but I hope it helps someone out in a similar situation. – user53029 Aug 23 '15 at 20:31
  • That is an interesting answer in your comment - could you add it as an actual answer to your question? (Comments may get lost, and the question would not stay unanswered forever.) – Volker Siegel Nov 24 '15 at 11:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.