2

So I got my Fedora 22 as I finally decided to switch from Fedora 20 ( been using it forever, found it kinda hard to detach )

The problem is that I bought my new docking station for multiple monitors and it simply does not work. There is one display port on it and two HDMI ports for monitors and a bunch of USB 3.0 ports.

I know there are issues with display ports but I am not even using it all the monitors go over HDMI and the docking station is connected to the laptop via USB 3.0 as well

I ve looked online for the drivers with no luck also for some people it seams to work on Ubuntu 15.04.

Could anybody help me out.

Thank you for your time.

1 Answer 1

3

The drivers are available for Ubuntu at displaylink.org here:

http://www.displaylink.com/downloads/ubuntu.php

But people have had to modify the installation scripts depending on their setup/distro with mixed success. For now, DisplayLink are only focusing on Ubuntu.

There is a pretty good thread on the D3100 if you scroll down near the end here (starting from 8/4/15, this is recent stuff):

http://www.displaylink.org/forum/archive/index.php/t-1748.html

6
  • Okay so I go the displaylink drivers for ubuntu, some people have managed to get it work on Fedora 22 so I looked at how they modified the installation script and I used that, the installation seams to have worked once and once alone and I could detect my other monitors but I could not enable them at all so I tried reinstalling and after the reinstallation I could no longer even see the monitors in system settings. now I can not even start the displaylink service with systemctl, log files state the following: Commented Aug 24, 2015 at 14:10
  • Failed at step EXEC spawning /usr/lib/displaylink/DisplayLinkManager: No such file or directory Commented Aug 24, 2015 at 14:12
  • So what I did was copy DisplayLinkManager to /usr/lib/displaylink and gave it the 0755 permissions as the installation script would do. But I still keep getting the same error message even though the file is there. Commented Aug 24, 2015 at 14:14
  • OMG so finally after I had to do everything manually prior to the installation and than more work after I managed to get it to work and recognize my other monitor, but now I got a different problem. Even though I can see the other monitor I can not enable it in system settings and I haven't got a clue why, could you help me out figure it out. Commented Aug 24, 2015 at 16:09
  • I don't have the D3100 personally, so beyond the links above there's not much I can do. You might try reading through the installation shell script and see if it does anything to enable it - maybe adding something to X11 config?
    – Oliver
    Commented Aug 26, 2015 at 21:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .