8

Issue: After my laptop comes back from suspend and I log in via lightdm, I have to use the mouse to open a terminal then type on the command line before my keyboard is responsive. I usually close the laptop with Firefox maximized and that is what is at the forefront after login. However, the keyboard is unresponsive in firefox until I've done as described above, type in a console. The keyboard is functional to allow me to login at lightdm's prompt, but not once having unlocked the system. I've turned off xscreensaver and still experience the issue. I've turned off lightlocker and still experience the issue.

System:

  • Lenova G50 laptop
  • Ubuntu 15.04
  • lightdm (1.14.02)
  • xfce
  • xfwm4 (4.12.13)
  • xscreensaver (5.30)
1
  • Does it only work with a terminal or does it work with other applications? Does switching to a running terminal work? Which terminal emulator are you using, does it work with others? Do you have this problem only when Firefox is focused or also with other applications? Aug 22, 2015 at 20:10

1 Answer 1

3

Found an answer which works for me here. The problems seems to be:

Apparently xfce4-power-manager and systemd were both creating suspend events at the same time, causing problems loading modules like keyboard drivers upon resuming.

If the xfce-power-manager is used to handle suspend, it is suggested to edit /etc/systemd/logind.conf and add:

HandlePowerKey=ignore
HandleSuspendKey=ignore
HandleHibernateKey=ignore
HandleLidSwitch=ignore
2
  • 3
    I actually already had this in my logind.conf with no positive result. I did discover gnome-screensaver and xscreensaver running, which leads me to believe that the two were creating a keygrab conflict. I purged xscreensaver to doubly ensure it wouldn't run in the future and I haven't had the issue since, but I've tried so many things at this point, I can't say for certain what has made the difference.
    – rezzrovv
    Oct 5, 2015 at 11:32
  • A similar thing happened to me when Xubuntu 19.10 came out with xfce-screensaver – I turned off xfce-screensaver (I thought!) because I wanted to stay with light-locker, but it still grabbed the keyboard some times. Completely uninstalling xfce-screensaver fixed it.
    – unhammer
    Feb 19, 2020 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.