3

I've setup mutt on Ubuntu to work with my gmail. It works if I change the setting in gmail "Allow less secure apps" to ON but I'd rather connect securely. I have OpenSSL installed. When I do mutt -v I get:

Compile options:-DOMAIN +DEBUG -HOMESPOOL+USE_SETGID+USE_DOTLOCK +DL_STANDALONE +USE_FCNTL-USE_FLOCK +USE_POP +USE_IMAP +USE_SMTP -USE_SSL_OPENSSL +USE_SSL_GNUTLS +USE_SASL +USE_GSS +HAVE_GETADDRINFO +HAVE_REGCOMP -USE_GNU_REGEX ....etc...

Do I need to recompile mutt but with the USE_SSL_OPENSSL option enabled? If so, how do I do that (I couldn't find instructions)? Or should I go about it differently? I don't even know if this will solve my problem. I've searched every angle I can think of and reinstalled several times. apt-get install mutt and apt-get install openssl mutt seem to do the same things. Any advice would be greatly appreciated. Thanks!

7

As described in this announcement, this is not directly related to either mutt or openssl but effects all non-OAuth mail clients equally. What google considers "less secure apps" is in no way insecure if proper encryption is used (as should be the case with mutt and openssl).

If one still wants some additional security, turning on two-factor authentication and using a separate password could be an option.

  • 1
    Thanks for the link, @tarleb. I've gotten the impression from some other posts on this issue that you can configure Mutt to make google happy. From your link I did end up here: ghacks.net/2014/07/21/… and turned on 2-step authentication to see if it works but unfortunately, it did not. There must be a way to configure mutt to meet google's requirements as according to this thread: unix.stackexchange.com/questions/172666/gmail-blocking-mutt but again, the problem persists. – Kapunahele Wong Aug 21 '15 at 22:31
  • @KapunaheleWong Did you try setting an application specific password for mutt? The linked resources support the assumption that application specific passwords are the way to go here (sorry if that wasn't clear from my answer). – tarleb Aug 22 '15 at 8:39
  • 3
    Yay!! That worked! :D Thanks sooooo much! To summarize for anyone in the furture - for gmail + mutt, you have to allow less secure apps OR turn on 2-step authentication and then generate a password for mutt. Then at the mutt password prompt, put in that password. – Kapunahele Wong Aug 22 '15 at 12:52
  • Less secure apps are not allowed while 2 factor auth is switched on. The way to solve this is to use "App specific passwords". – CMCDragonkai Oct 18 '17 at 2:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.