0

I am trying to install a GUI onto my fedora21 virtual machine. The only problem is due to the nature of work i am doing it needs to be done through the command line( i am using a program called putty), Can anyone help me out with this?

The commands i have run to install a GUI is a simple

yum grouplist 
yum groupinstall "Fedora Workstation" --skip-broken 

This is where i get the error. That tells me that there are no packages in any requested group to install the update.

  • The correct answer here depends on what you want to do. You say "Fedora server" — do you mean the Fedora Server edition, or do you mean this in a generic sense? How was the VM installed initially? You say that you are accessing the system with putty, which is an SSH client for Windows. You won't be able to access any GUI through putty — is that okay, and in that case, what is the purpose? Do you want specifically to convert the system to Fedora Workstation, or do you just want a GNOME desktop (or any desktop)? Depending on your use case, have you considered the Cockpit web GUI? – mattdm Apr 13 '16 at 22:15
1

Wow, thanks:

In Fedora 31 Server I tried KDE, I tried cinnamon, all in su - user mode. Then I searched and found this post: groupinstall in su - user mode

yum grouplist
yum groupinstall "Fedora Workstation" --skip-broken

Used startx an old command I read of. And the Fedora Server is now GUI. Thanks a bunch.

-1

Have you tried to configure local yum server and local repositories for it?

If no then please follow this link, and just start from the YUM configuration.

I have mentioned the steps below as well:

For GUI interface in RHEL 6.2 follow below steps:::

For GUI interface in RHEL 6.2 you have to install all the gnome packages of RHEL 6.2. Using rpm it is not easy to install above 240 packages, So you have to install YUM(Yellow-Dog Update Manager)Server for that. Steps to install and Configure YUM Server For the local system:

  1. Insert RHEL 6.2 DVD in DVD drive

  2. Mount that dvd to /mnt using below command

    mount /dev/dvd(or cdrom) /mnt

  3. Install vsftpd package using below command

cd /dev/dvd/Packages(or Server) where the all packages are there and then,

Fire command

#rpm –ivh vsftpd(then press Tab Button so you will get the whole package name) then press

Enter button

  1. Then install some needy packages using below command

rpm –ivh deltarpm(then press Tab Button so you will get the whole package name) then

press Enter button

rpm –ivh python-deltarpm(then press Tab Button so you will get the whole package name)

then press Enter button

rpm –ivh createrepo(then press Tab Button so you will get the whole package name) then

press Enter button

  1. copy all the packages from dvd to the system using below command

    cp –av /mnt/Packages /var/ftp/pub/yum/Server

  2. then you have to configure a file named base.repo. for that follow below steps:

hit below command

hostname serpent

  vi /etc/yum.repos.d/base.repo

by pressing Shift+I key you will able to edit in that file. edit below things

[Server]
name=serpent
baseurl=file:///var/ftp/pub/yum/Server
enabled=1
gpgcheck=0

then press ESC button

then write below thing

  :wq!

And press enter …. You have configured this file …

  1. now put below command to create repository of the packages

    createrepo /var/ftp/pub/yum/Server/

  2. now check the configuration of yum server using below command

    yum update all

if you see all the packages updated [################ 100%] with this sigh.

  1. Then put below command for installing needy packages for GUI using yum

yum install gnome*(* is for all packages related to this name) then press y and enter button

then install below packages as the same

 yum install kde*  
  yum install X*  
  yum install xorg*  
  1. After installing these packages type below command

    startx

Now you will get the GUI interface!

When you login the server, after login in if you do not get the display then you just type below command every time.

  • Thanks for the help! Would it work the same way even if i am using a virtual machine? – MesamH Aug 21 '15 at 13:00
  • Yes it will work surely in the VM as well :) – keyur bhatt Aug 24 '15 at 4:59
  • I don't think this RHEL 6.x answer applies very well to Fedora. There are also some very odd irrelevant instructions. Deltacloud isn't even a thing anymore..... – mattdm Apr 13 '16 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.