I have a centOS VM that when I lock the screen it will not let log me back in. I can enter my password as many times as I'd like, even try to "switch users" but the VM just ignores everything and keeps me logged out. I then have to do a restart.

I have both a domain user and local user, both are ignored when trying to log back in. Root does not allow a lock screen, and another person using this VM has both local and domain accounts as well. However he can log back in, but only with his local account. Besides root (obviously) all accounts have the same privileges.

Any idea on what's going on, or how to fix it?

CentOS 6.7

  • Are there any interesting logs, like in /var/log/secure or /var/log/messages or similar? Commented Aug 20, 2015 at 15:44

4 Answers 4


In VSphere hold down the left mouse button over the screen and move up.

  • I had a same issue and this helped. I have a vSphere from which I access the CentOS guest OS and a screensaver would popup as shown at superuser.com/questions/869075/… - clicking mouse, trying any commands with keyboard, Esc key, C+A+D did not work and what is mentioned here worked. Just like how you do in smartphone. Only catch is that it did not work always and I had to click couple of times to get the mouse click work. Commented Sep 8, 2016 at 6:40
  • 1
    This worked with CentOS 7 (under VirtualBox).
    – Asclepius
    Commented Nov 16, 2016 at 7:45

Press the Enter twice in VMware.

  • Terse, but worked in Hyper-V, Windows 10 Pro
    – ixe013
    Commented Oct 14, 2016 at 2:04
  • This worked with CentOS 7 (under VirtualBox).
    – Asclepius
    Commented Nov 16, 2016 at 7:47

Press Ctrl and scroll up to open login window. Works for me with VMware and Hyper-V hosts, and CentOS 7 as guest.


In VSphere Client Only press Escape key it will unlock screen of centos

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .