1

I get the following error when I try to run armitage, and furthermore I get errors when i try to install certain packages or when I run certain software.

root@Xeno:~# armitage
Exception in thread "main" java.lang.UnsatisfiedLinkError: /usr/lib/jvm/java-7-openjdk-i386/jre/lib/i386/xawt/libmawt.so: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.16' not found (required by /usr/lib/i386-linux-gnu/libkrb5.so.3)
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1965)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1890)
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1851)
    at java.lang.Runtime.load0(Runtime.java:795)
    at java.lang.System.load(System.java:1062)
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1965)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1890)
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1872)
    at java.lang.Runtime.loadLibrary0(Runtime.java:849)
    at java.lang.System.loadLibrary(System.java:1088)
    at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:67)
    at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:47)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.awt.Toolkit.loadLibraries(Toolkit.java:1657)
    at java.awt.Toolkit.<clinit>(Toolkit.java:1686)
    at java.awt.Component.<clinit>(Component.java:595)
    at armitage.ArmitageMain.main(ArmitageMain.java:199)

Error log from when I tried adding the needed repository for notepadqq :

root@Xeno:~# sudo add-apt-repository ppa:notepadqq-team/notepadqq
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 8, in <module>
    from softwareproperties.SoftwareProperties import SoftwareProperties
  File "/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py", line 53, in <module>
    from ppa import AddPPASigningKeyThread, expand_ppa_line
  File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 27, in <module>
    import pycurl
ImportError: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.16' not found (required by /usr/lib/i386-linux-gnu/libkrb5.so.3)

Here is an example of trying to install a package(libc, wich i have problems updating):

root@Xeno:~# sudo apt-get install libc6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libc-dev-bin : Depends: libc6 (< 2.14)
 libc6-dev : Depends: libc6 (= 2.13-38+deb7u8)
 libc6-i686 : PreDepends: libc6 (= 2.13-38+deb7u8)
 locales : Depends: libc-bin (> 2.19) but 2.13-38+deb7u8 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Here is my libc version: root@Xeno:~# dpkg-query -l libc6

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name              Version       Architecture  Description
+++-=================-=============-=============-=======================================
ii  libc6:i386        2.13-38+deb7u i386          Embedded GNU C Library: Shared librarie

Now, the main thing is I want armitage to run again and I want packages to be able to be installed again. I strongly think updating the libc(glibc) version( to version 2.16 '[...]version `GLIBC_2.16 not found[...]') is the answer, but I can't seem to find a way to do it. How can I do that?

P.S. I know i have dublicate entries in the sources.list file but that shouldn't be an issue.

I tried running apt-get dist-upgrate as suggested by Gilles and it returned the following log :

root@Xeno:~# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libkrb5-3 : Depends: libc6 (>= 2.16)
 libtirpc1 : Depends: libc6 (>= 2.16)
 locales : Depends: libc-bin (> 2.19) but 2.13-38+deb7u8 is installed
E: Unmet dependencies. Try using -f.

Sources.list file contents:

 ## Regular repositories
    deb http://http.kali.org/kali kali main non-free contrib
    deb http://security.kali.org/kali-security kali/updates main contrib non-free
    deb http://http.kali.org/ /kali main contrib non-free
    deb http://http.kali.org/kali debian-wheezy main contrib non-free
    ##deb http://http.kali.org/kali kali-dev main contrib non-free
    ##deb http://http.kali.org/kali kali-dev main/debian-installer
    deb http://http.kali.org/kali kali main contrib non-free
    deb http://http.kali.org/kali kali main/debian-installer
    ## Source repositories
    deb-src http://http.kali.org/kali kali main non-free contrib
    deb-src http://security.kali.org/kali-security kali/updates main contrib non-free
    ##deb-src http://http.kali.org/kali kali-dev main contrib non-free
    deb-src http://http.kali.org/kali kali main contrib non-free

1 Answer 1

3

Upgrading libc is not recommended. You'll end up upgrading a lot of other packages. That's what the message about unmet dependencies is telling you: if you upgrade libc, you need to upgrade a bunch of other packages.

The reason those other packages aren't getting upgraded is either because you forgot to run apt-get update or because you have preferences in /etc/apt/preferences or /etc/apt/preferenced.d/* that make some newer packages installable only by explicit request.

What you should do is just upgrade the whole distribution. Kali Linux currently has Glibc 2.19. Check that your sources are reasonable, run apt-get update, run apt-get dist-upgrade and go for a walk while the packages are being downloaded and unpacked.

5
  • I run apt-get update very often, so that shouldn't be an issue. Next, I tried your sugestion on running apt-get dist-upgrade. Turns out I didn't have to go for a walk, it returned a error log (again, pointing out that the libc version isn't right). My /etc/apt/preferences.d/ folder is empty( I checked for hidden files). Do you have any ideeas about what I could do now?
    – XenoWad
    Aug 20, 2015 at 22:46
  • @XenoWad Make sure you've run apt-get update first. If it still doesn't work, post your sources (/etc/apt/sources.list and any file in /etc/apt/sources.list.d). Aug 20, 2015 at 23:11
  • I updated the question with sources.list file contents, the /etc/apt/sources.list.d folder is empty( again, I checked for hidden files).
    – XenoWad
    Aug 20, 2015 at 23:38
  • Do you think i should reinstall kali linux?I had lots of problems with it(fixing mute sound was hell on earth ,getting apt-get install to work, getting the wireless card to get recognised and start wifi...)
    – XenoWad
    Aug 21, 2015 at 8:42
  • I edited the sources.list file contents(I commented out the 'dev' repositories as sugested here unix.stackexchange.com/questions/223933/… .
    – XenoWad
    Aug 21, 2015 at 22:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .