I am using a Debian unstable with Iceweasel (38.2.0esr-1) and the Enigmail plugin (2:1.8.2-3) from the distribution packages. I recently upgraded my system and got a new version of the gnupg2 package (2.1.7-2, previous was 2.0.28-2) and I ran into problems when trying to use my private key (encrypt, decrypt, sign messages) in Enigmail since then. The error message is:

Enigmail: Error - no matching private/secret key found to decrypt message; click on 'Details' button for more information

And, the 'Details' button was giving the following error message:

Enigmail Security Info
Error - no matching private/secret key found to decrypt message
gpg: decryption failed: No secret key
Note: The message is encrypted for the following User ID's / Keys:
  0xAAAAAAAAAAAAAAAA (Surname Name <[email protected]),

Note also, that, if I save the e-mail in a flat file and use the gpg2 --decrypt command line, it works like a charm without any visible problem.

I looked in the Debian BTS about Enigmail and found a bug with similar characteristics (Debian Bug #794627). It has not been solved because the maintainer cannot reproduce the bug.

I tried several things with no success, so if you encounter this bug and find something about it, I would be pleased to know how to solve it. Any input is welcome.

  • try apt-get install -f
    – gwillie
    Aug 19, 2015 at 9:23
  • 1
    @gwillie: In fact, what you propose is simply irrelevant because it is a bug inside a packet (and not 'about the dependancies of my system').
    – perror
    Aug 19, 2015 at 9:26

2 Answers 2


In fact, the problem is linked to the usage of the gnome3-pinentry software when agent has no default DBUS_SESSION_BUS_ADDRESS.

Here is the thread on the Debian BTS (Bug Tracking System) Website about this problem.

It finally turned out that the default pinentry software is working as expected, but the Gnome3 version has some quirks about dispatching some variables. Here is the patch applied by the Debian Enigmail maintainer to fix the problem:

enigmail (2:1.8.2-4) unstable; urgency=medium

  * pass through {GTK,QT}_IM_MODULE, XMODIFIERS, and
    DBUS_SESSION_BUS_ADDRESS so that modern pinentry works. (Closes: #794627)
  * correct reported version number of enigmail

 -- Daniel Kahn Gillmor <[email protected]>  Thu, 20 Aug 2015 00:23:48 +0200

Since you can correctly decrypt using GPG via command line, it looks like it's an issue with the Enigmail configuration. Open Iceweasel, go to Account Settings -> OpenPGP Security and verify that:

  • Enable OpenPGP support for this identity is checked
  • Use specific OpenPGP KeyID is checked and set to the ID of your key pair

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .