0

I just bought a USB wi-fi dongle using the MediaTek MT7610U (RT2860) chipset, and the drivers from their website: http://www.mediatek.com/en/downloads1/downloads/mt7610u-usb/ won't compile, with this error

ktweed@PC-BL100TA ~/Desktop/drivers $ make
make -C tools
make[1]: Entering directory `/home/ktweed/Desktop/drivers/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/home/ktweed/Desktop/drivers/tools'
/home/ktweed/Desktop/drivers/tools/bin2h
chipset = mt7650u
chipset = mt7630u
chipset = mt7610u
cp -f os/linux/Makefile.6 /home/ktweed/Desktop/drivers/os/linux/Makefile
make -C /lib/modules/3.2.0-89-generic/build SUBDIRS=/home/ktweed/Desktop/drivers/os/linux modules
make[1]: Entering directory `/lib/modules/3.2.0-89-generic/build' 
make[1]: *** No rule to make target `modules'.  Stop.
make[1]: Leaving directory `/lib/modules/3.2.0-89-generic/build'
make: *** [LINUX] Error 2

I tried using files modified according to this site, with the same error:
http://earthwithsun.com/questions/738096/how-to-install-mediatek-mt7610u-rt2860-driver

LSUSB output

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0408:13fd Quanta Computer, Inc. 
Bus 001 Device 003: ID 148f:7601 Ralink Technology, Corp.

The Ralink one is the USB Wifi.

ifconfig output:

eth0      Link encap:Ethernet  HWaddr 00:0d:5e:ed:d3:4e  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:42 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:5538 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5538 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:609333 (609.3 KB)  TX bytes:609333 (609.3 KB)

I'm running linux mint 13 XFCE 32-bit. I've tried everything, and nothing works. If anyone could help, that would be great. Thanks!

Edit: The CD that came with the USB Wifi has drivers for a realtek 8188CUS, and those don't work either. Does this help?

0

From lsusb output, 148f:7601, it should be a MT7601U chip not MT7610U. Please node, Mediatek official site seem swap the link between them, but I'm not very sure about this.

I believe some guys have made good progress on MT7601U, refer to https://github.com/kuba-moo/mt7601u

You can see, that driver are committed to 4.2 kernel.

I have a MT7610U usb adapter, I'm very sure I cannot use MT7601U driver, after I've tried so many drivers. My adapter lsusb output:

Bus 001 Device 007: ID 0e8d:7610 MediaTek Inc.

0

Give a shot on kernel 4.19 or above. This version should work smoothly because there is native support for mt7610u.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.