1

OK, I would never do this on a system that I was running, but I'm having to build on a server that I don't administer. To test out how to do I have a "dummy" project that I'm trying to build on the server. When I run

./configure

I get an error that the intltool version is out of date (0.35 is needed, system has 0.31.2). The server is running RHEL 4.8.

The sysadmin says the intltool package on the server can't be upgraded (why?). He has had me install an up-to-date intltool in my home directory. The install seems to work. i.e. I wget the package file, untar it, go into the directory and then run

./configure --prefix=$HOME/intltool
make clean
make
make install

and that all runs with no errors. But now going back to my project and try

./configure

and I still get the error about an out-of-date intltool. Running

intltool-update --version

tells me the system is still using the old version. Is there some environment variable I can set to direct the system to use the intltool version that is in my home directory? I've asked the sysadmin, of course, but I figured I might get a quick answer from someone here.

Alternatively, is there an edit to the configure file in my project which would direct it to use the new intltool install?

0

The solution was easy. I just hadn't set the PATH variable correctly. The new intltool directory in my home directory had to be added to PATH. I had actually tried to do this but had messed up the command to set it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.