3

I would like to update my OCaml distribution from version 4.01 to version 4.02, in particular the ocaml-nox package. This breaks the dependencies of several other packages that explicitly require 4.01. In my case, libctypes-ocaml[-dev] v0.2.3, libfindlib-ocaml[-dev] v1.4.1 and ocaml-findlib v1.4.1 have this dependency.

I could not find updates for the dependent packages and the maintainers told me in a one-liner that the situation might not change any time soon. Is there any way for me to proceed with the update anyway (assuming that all packages would indeed work with 4.02)? Can I for example trick aptitude into believing that the new versions are also fine?

2
+50

You need to rebuild the packages for the new ocaml version by yourself or wait until Debian does it officially.

For rebuilding, e.g. follow this general tutorial: https://wiki.debian.org/BuildingTutorial

There is already a transition in Debian ongoing where all OCaml packages are rebuild automatically for the new OCaml version. You can find details for this and related problems in the Bug tracking system. Rebuild packages for the amd64 architecture can be found already here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.