6

In new version of Kali 2.0 with updated "aircrack-ng" tool, there is a problem between Internet connection and using cracking tools.

I have my wireless card as wlan0. And the Internet connection is fine too. Then, what I do is:

airmon-ng start wlan0
airodump-ng wlan0mon

Now the airodump-ng doesn't work, saying "Device or resource busy".

In order to run this I have to kill some processes, using:

airmon-ng stop wlan0
airmon-ng check kill
airmon-ng start wlan0
airodump-ng wlan0mon

Now the cracking process is up.

I can start cracking, but now I cannot connect to the Internet after the kill process.

On typing iwconfig in terminal, I get this:

root@kali:~#iwconfig
wlan0mon IEEE 802.11bgn  ESSID:"myessid"  
      Mode:Managed  Frequency:2.412 GHz  Access Point: 00:00:00:00:00:00   
      Bit Rate=108 Mb/s   Tx-Power=20 dBm   
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Encryption key:off
      Power Management:off
      Link Quality=42/70  Signal level=-68 dBm  
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:2  Invalid misc:9   Missed beacon:0

eth0      no wireless extensions.
lo        no wireless extensions.

And, on running ifconfig on terminal, I get this:

root@kali:~#ifconfig
lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:5604 errors:0 dropped:0 overruns:0 frame:0
      TX packets:5604 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:452904 (442.2 KiB)  TX bytes:452904 (442.2 KiB)

There is no wlan0 or wlan0mon. I also restarted the network manager by:

service network-manager restart

But nothing changed. Though it displays wlan0 when checked using ifconfig this time.

4

I had nearly the same issue. After messing around with airmon-ng I couldn't connect to any networks. Even the network manager icon disappeared from the taskbar (KDE). If I checked iwconfig, I would see eth0, lo, and wlan0mon instead of just wlan0. Doing:

ifconfig wlan0 up 

just told me no such device exists. That clued me into how to potentially fix the mode.

Here are the commands that restored my internet access:

First, restart your network manager:

 service NetworkManager restart

(Your network manager service might be called Network-Manager)

Let's see what your wireless adapter is doing:

 iwconfig

(It might be called something like wlan0mon instead of wlan0 indicating it is in monitor mode still)

Since it is still in monitor mode, let's turn the normal mode back on:

 airmon-ng start wlan0 7

(The last number is the channel and can probably be omitted)

Now let's stop the monitoring interface:

 airmon-ng stop wlan0mon

And finally, let's turn your normal network adapter back on:

 ifconfig wlan0 up

Check for the normal adapter now:

 ifconfig

(Should no longer show the "mon" equivalent and instead show wlan0 or whatever your adapter is called in normal mode)

Now you can use your network manager app to reconnect to the network for browsing.

Not sure why I haven't seen this solution. Most end up rebooting to get back to normal internet mode.

2

For now, on Kali 2.0, the only solution I've found for this is to reboot. I've tried 3 different USB adapters with compatible chipsets, in a dual-boot environment and in a VM, and I've tried countless ways to reconnect to the internet after killing the appropriate processes for airmon. No combination that I've tried has ever regained internet connectivity. I add this here as it is an accurate, though unfortunate, solution, in hopes that the answer can be improved upon.

2

Don't use the airmon-ng check kill command to fix any errors or problems, instead, use the following commands to start monitor mode:

$> sudo ifconfig wlan0 down
$> sudo iwconfig wlan0 mode monitor
$> sudo ifconfig wlan0 up
$> sudo aireplay-ng wlan0

protected by Community Oct 9 '15 at 16:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.