0

I have a Samsung NP900X4D laptop and I would like to replace the existing Windows 8 installation with a Debian 8.

At first, I copied Debian 8 hybrid iso image to a USB flash drive with cat debian-8.1.0-i386-CD-1.iso > /dev/sdc; sync. Now, when I try to boot my IBM T43 from this USB thumb drive, then it works fine and I am able to install Debian.

However, the Samsung NP900X4D does not boot from this USB flash drive despite that I have disabled "Fast BIOS Mode" and "Secure Boot".

If I insert the USB flash drive either to USB 3.0 or USB 2.0 port, turn on the laptop and enter UEFI "Boot Menu". Then, it contains only the "Windows Boot Manager", but I would have expected to see a list of boot options(PXE, USB flash drive, SSD, etc) there:

enter image description here

What might cause such behavior?

2
+200

If you have tried everything in the bios and nothing works try using a few different USB keys, the problem may be the key and not the system.


I work with a lot of embedded systems and one painful lesson that has been learned is not all USB keys are created equal.

We had an issue where sometimes we could boot from USB keys and other times it would fail. Eventually we found that we had to power cycle the system after the USB key was attached before it was seen, if the system was just rebooted the key would never be detected.

We got a few more keys in from big brands such as Sandisk and Kingston and since we started using these keys we have not seen an issue.

Oddly enough the bad keys work perfectly with almost all systems the issue was tied to a specific type of key in a specific type of system.

Note that the key should be visible in the bios even if it is not bootable, you don't need to put an image on each key to try this, you can just plug them in as they are.

  • I tried with five different USB keys, but while I was able to boot from all of those on my IBM T43, they did not appear in Boot Menu of NP900X4D. I tested those in a way that I turned off the laptop, inserted the USB key and then turned the laptop on and went to UEFI. The USB keys were powered on because SanDisk and Sony ones have a small LED which was lit. I tried both with USB 2.0 and USB 3.0 ports. – Martin Aug 25 '15 at 17:55
0

I would look for BIOS section called something like BOOT DEVICES. Sometimes, devices need to be prioritized before they can be chosen from.

  • There isn't such option. Closest to this is boot menu, but this does not contain such options. Picture of Boot Device Priority screen can be seen in my initial post. As I already mentioned, I would have expected to see a list of boot options(PXE, USB flash drive, SSD, etc) there.. – Martin Aug 18 '15 at 17:08
0

Looking at your image of the boot menu it seems you have 'Secure Boot' disabled, with 'OS Mode Selection' set to 'CMS OS' (Compatibility Support Module OS) but disabled by it's parent.

I'd suggest enabling 'Secure Boot', ensuring 'OS Mode Selection' is still set to 'CMS OS', and then seeing what is in the 'Boot Menu'.

Edit:

You may also want to try setting 'Secure Boot' and 'Fast BIOS' to disabled, rebooting, re-entering the BIOS, and then seeing what options you have under 'Boot Priority Order'

  • If I enable Secure Boot, then I can no longer choose between UEFI OS, CSM OS and UEFI and CSM OS. However, if Secure Boot is enabled, then Windows Boot Manager is still the only "device" in Boot Priority Order. If I disable both Secure Boot and Fast BIOS Mode, save the changes and reboot, then I can still see only the Windows Boot Manager in Boot Priority Order. – Martin Aug 18 '15 at 21:57
  • Could you attempt to boot from a copy of Ubuntu newer than 12.10/12.04.2 with 'Secure Boot' enabled? Not ideal but from there you might be able to install Debian using debbootstrap. It's my understanding that newer versions of Ubuntu support 'Secure Boot' out of the box. – p8952 Aug 19 '15 at 15:13
  • I tried this, but the thing is, that laptop does not even try to boot from anything other than SSD, i.e it boot directly into Windows Boot Manager. – Martin Aug 20 '15 at 0:56
0

What kind of filesystem is the USB device using? AFAIK most systems only support FAT32 (Some UEFI motherboards support more than that) - and then you must have the EFI bootblock in the appropriate location in the USB filesystem.

FURTHERMORE - you are using a 32-bit ISO it appears. To boot with EFI, you MUST use a 64 bit version of a debian distro.

If you can't see the device in the boot menu, it's because the UEFI on your motherboard cannot find any suitable EFI boot block on the device.

  • Secure boot and EFI boot are different. Although they are related, you should not need Secure boot enabled to do an EFI boot. In fact, Secure boot can make EFI booting into a *nix system considerably more difficult. – IceMage Aug 24 '15 at 18:27
  • I have tried with USB keys with EFI(file-system ID ef) and FAT32(file-system ID c). I have tried with debian-8.1.0-amd64-netinst.iso image as well. – Martin Aug 25 '15 at 18:43
  • 1
    Do you have secure boot enabled? Secure boot should be disabled to ensure that the system will actually allow for you to use the USB drive to boot from. Also, the USB key won't show up in that list of boot options, generally because there is no entry within your computer's EFI table for the USB key. What should happen, is when you go to boot, you should have an option for EFI CD/DVD and EFI USB, your motherboard may not display that option from within the "BIOS" – IceMage Aug 28 '15 at 20:36
  • I have "Secure Boot" disabled and I have tried with five different USB keys in all three USB ports. All those five USB keys did boot in my T43 laptop. Looks like I have a similar issue with this one. However, I still haven't found a way to fix this. – Martin Aug 29 '15 at 0:23
0

Turned out, that BIOS was corrupted. I was able to start Command Prompt in Windows Recovery and reset UEFI variables with sflash64.exe utility:

Re-flashing the BIOS would have helped also. After that I was able to choose a boot device:

  • hello Martin, hope you will read this, I have the same problem, lost whole day allready, can you tell me more what you did ? how did you open that console in recovery mode ? I was pressing f4 when laptop starting but in the recovery mode was not able to open any console, also where did you get Samsun_Update folder from ? – kosnkov Jun 28 '18 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.