2

I have a mail server in my ubuntu instance. I have a webserver management FROXLOR and i recieve errors for access denied when i try to login in mail account. The log for this:

Aug 16 03:14:33 email dovecot: auth-worker(15140): Error: mysql(127.0.0.1): Connect failed to database (froxlor): Access denied for user 'froxlor'@'localhost' (using password: YES) - waiting for 25 seconds before retry
Aug 16 03:14:58 email dovecot: auth-worker(15140): Error: mysql(127.0.0.1): Connect failed to database (froxlor): Access denied for user 'froxlor'@'localhost' (using password: YES) - waiting for 125 seconds before retry

I check in mysql and says this:

mysql> show grants for 'froxlor'@'localhost';
+----------------------------------------------------------------------------------------------------------------+
| Grants for froxlor@localhost                                                                                   |
+----------------------------------------------------------------------------------------------------------------+
| GRANT USAGE ON *.* TO 'froxlor'@'localhost' IDENTIFIED BY PASSWORD '*AAAAABBBBBCCCCCDDDDDEEEEE111112222333344444' |
| GRANT ALL PRIVILEGES ON `froxlor`.* TO 'froxlor'@'localhost' WITH GRANT OPTION                                 |
+----------------------------------------------------------------------------------------------------------------+
2 rows in set (0.00 sec)

In google search, the line GRANT USAGE on*.*says the grant is related to NONE permissions.

I have tried to REVOKE permissions, DROP user, GRANT ALL with GRANT OPTION, and GRANT ALL PRIVILEGES and always with FLUSH PRIVILEGES; and sometimes using service mysql restart.... but nothing solves this. Someone can help me? thanks in advance

0

In this case I think your mysql server in not listing over 127.0.0.1

Please check the following output

sudo netstat -tunlep

mysql server listen over port 3306. In netstat -tunlep output check whether the mysql server is listning over 127.0.0.1 or ::. If not make mysql server to listen over 127.0.0.1 also.

Also update your system's hostname correctly as follows

sudo vim /etc/hosts
127.0.0.1 localhost localhost.localdomain (other_entries,if any)
:: localhost localhost.localdomain (other_entries,if any)

If this doesn't fix then retrieve the password FROXLOR using from the configuration file of the software (I don't know the location of FROXLOR configuration, consult the software documentation)

Try login in to mysql server as user froxlor with the retrieved password from FROXLOR configuration in command line as follows.

mysql -u froxlor -p retrived_password

If this is working then FROXLOR shall also connect.

Don't forget to restart the mysql server after every steps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.