2

I'm running Arch Linux with the Gnome desktop environment. Using the Gnome settings I can add the dvorak keyboard layout and switch between with the shortcut key, but whenever start the computer the login screen has the qwerty keyboard set. As soon as I login, it's set back to dvorak though.

I've used setxkbmap -layout dvorak and localectl set-x11-keymap dvorak as detailed on the wiki here. But all they achieve is to remove the language toolbar from the login screen, so that I can't change to dvorak before login.

Where is the setting that allows me to specify the keyboard layout on the login screen?

UPDATE: Here is what my input sources settings look like:

enter image description here

7
  • I don't appear to have that button. See my updated question. Do you have any idea as to why it wouldn't be there? Nov 30, 2015 at 0:49
  • 1
    Are you fully up to date ? Then check this out: GDM defaults to en_US layout after upgrade to Gnome 3.16 Nov 30, 2015 at 0:51
  • Damn, it doesn't look like it's fixed yet. Do you know of any work arounds? Nov 30, 2015 at 0:56
  • 1
    Adding a new user made the Login Screen button appear. I didn't even have to log out of my user. I have my login screen layout settings the same as my user settings, see screenshot. But the default layout on the login screen is still US, and once I login it automatically switches to Dvorak. Dec 1, 2015 at 0:05
  • 1
    Yeah man, as per the bug report I linked to, if one of those layouts is US it will default to US. I don't know if there's a way to work around this... other than removing the US layout from the login screen layouts list... Dec 1, 2015 at 0:33

1 Answer 1

2

I've been using the Dvorak keymap on Gentoo for a very long time. There are three places where I set the keymap.

  • In GNOME Settings -> Keyboard
  • /etc/conf.d/keymaps
  • /etc/X11/xorg.conf.d/00-keyboard.conf

The Xorg conf file is the one that affects gdm login-screen. C̲o̲n̲t̲e̲n̲t̲ a̲s̲ f̲o̲l̲l̲o̲w̲s̲:

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbVariant" "dvorak"
EndSection

The usual caveats, YMMV, after configuration just reboot and it should work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .