2

I've been given for testing purpose a mobile receipt printer and I am trying to set it up in cups. I've successfuly connected to it via lubuntu blueman-manager and printed test page via cat testfile.txt > /dev/rfcomm0 and for the sake of some java application that will use it I need to set it up in cups. I get into cups web admin page, click add printer but the printer neither port are not found. Why? I've changed permissions under /usr/lib/cups/backend/ and now I have situation from screenshot![None printers available]1Now what?!

  • 1
    I believe there's an add-on package for bluetooth with CUPS, bluez-cups. Do you have that installed? – goldilocks Aug 15 '15 at 15:50
  • I did not have installed this package, I've installed it, restarted comp and same result, printer is not detected. – KernelPanic Aug 15 '15 at 16:25
1

Does CUPS not have an option for "generic serial printer"?

Then point it to /dev/rfcomm0

Have you checked the rights on: /usr/lib/cups/backend/serial and /dev/rfcomm0

May only root accessible?

Found this on Arch Linux Forum: (Solved) Generic Serial Printer

  • I've changed permissions on /usr/lib/cups/backend/ via sudo chmod -R 777 * and this was bad idea, since if I try to add printer under cups admin page, now I cannot add any printer since the list is empty! I've added screenshot under original question! – KernelPanic Aug 15 '15 at 18:46
  • 1
    yes, that was bad. chmod go+rx serial would have been better. – Alex Stragies Aug 15 '15 at 18:50
  • how do I revert this stupid mistake? – KernelPanic Aug 15 '15 at 18:57
  • 1
    Reinstall CUPS with 'apt-get install --reinstall cups' perhaps?. Or copy the rights for the 10 files in that folder from a different Installation. 'chmod go-w /usr/lib/cups/backend/*' and then go from there. – Alex Stragies Aug 15 '15 at 19:03
  • I have lubuntu will now reinstall whole cups! – KernelPanic Aug 15 '15 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.