1

I have been trying to use Armitage and I have been following this tutorial, and at step 2.2, I get these errors:

root@Xeno:~# service postgresql start
[....] Starting PostgreSQL 9.1 database server: main[....] 
perl: warning: Setting locale failed. 
perl: warning: Please check that your locale settings: 
    LANGUAGE = (unset), 
    LC_ALL = (unset), 
    LANG = "en_US.UTF-8" 
    are supported and installed on your system. 
perl: warning: Falling back to the standard locale ("C"). 
Error: could not exec /usr/lib/postgresql/9.1/bin/pg_ctl /usr/lib/postgresql/9.1/bin/pg_ctl start -D /var/lib/postgresql/9.1/main -l /var/log/postgresql/postgresql-9.1[FAIL.log -s -o -c config_file="/etc/postgresql/9.1/main/postgresql.conf" : ... failed!
 failed!
root@Xeno:~# service metasploit start
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
[FAIL] Postgresql must be started before Metasploit ... failed!

I have ran metasploit before and worked just fine. So, can someone explain to me why do I need to do this and what these databases mean and what role do they play.

Ok, so I tried running Armitage from the console and the Kali Linux tab in aplications, the output wasn't what I got before (yesterday it started just fine).

root@Xeno:~# armitage
Exception in thread "main" java.lang.UnsatisfiedLinkError: /usr/lib/jvm/java-7-openjdk-i386/jre/lib/i386/xawt/libmawt.so: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.16' not found (required by /usr/lib/i386-linux-gnu/libkrb5.so.3)
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1965)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1890)
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1851)
    at java.lang.Runtime.load0(Runtime.java:795)
    at java.lang.System.load(System.java:1062)
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1965)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1890)
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1872)
    at java.lang.Runtime.loadLibrary0(Runtime.java:849)
    at java.lang.System.loadLibrary(System.java:1088)
    at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:67)
    at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:47)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.awt.Toolkit.loadLibraries(Toolkit.java:1657)
    at java.awt.Toolkit.<clinit>(Toolkit.java:1686)
    at java.awt.Component.<clinit>(Component.java:595)
    at armitage.ArmitageMain.main(ArmitageMain.java:199)

Apart from this metasploit starts normaly, no issues there. Gnome tweak tool instalation error log (regarding libsc6):

root@Xeno:~# apt-get install gnome-tweak-tool
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 gnome-tweak-tool : Depends: gsettings-desktop-schemas (>= 3.6) but 3.4.2-3 is to be installed
                    Depends: gir1.2-gtk-3.0 (>= 3.12) but 3.4.2-7 is to be installed
                    Depends: gir1.2-gnomedesktop-3.0 but it is not going to be installed
                    Depends: gir1.2-notify-0.7 but it is not going to be installed
 libkrb5-3 : Depends: libc6 (>= 2.16)
 libtirpc1 : Depends: libc6 (>= 2.16)
 locales : Depends: libc-bin (> 2.19) but 2.13-38+deb7u8 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution)

I have been getting a lot of errors about libsc6 when i was trying to install other packages.While i looked through past terminal commands i found this:

apt-get install libasound2 libc6 libgcc1 libqt4-dbus libqt4-network libqt4-webkit libqt4-xml libqtcore4 libqtgui4 libstdc++6 libx11-6 libxext6 libxss1 libxv1

I was trying to fix an error regarding skype not detectiong any sound devices.

I have encountered some errors while trying to run sudo apt-get update so that I can update glibc version (2.16) needed by armitage and I figured I should ask another question regarding this :https://unix.stackexchange.com/questions/223933/sudo-apt-get-update-getting-errors-and-warnings

0
1

It seems that you updated your libc6 shared library required by a Kerberos library that is needed by Armitage to run.

Here is the interesting part of the error log thrown by Armitage:

Exception in thread "main" java.lang.UnsatisfiedLinkError: 
/usr/lib/jvm/java-7-openjdk-i386/jre/lib/i386/xawt/libmawt.so:
/lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.16' not found 
(required by /usr/lib/i386-linux-gnu/libkrb5.so.3)

So, you need to install the Kerberos shared library in a version that will recognize your current libc6 shared library to get Armitage to run.

Another thing is that your PostgreSQL seems to fail to start. You should also investigate this. It is very likely linked to the problem of compatibility with your new libc6 version.

A system is not something that correct itself its own bugs, you should really pay more attention to the logs and the error messages and try to solve as many problems as you can if you want an healthy (and working) system.

7
  • Thank you for the feedback! I will look into this some more.
    – XenoWad
    Aug 15 '15 at 11:11
  • Also when i was trying to install gnome tweak tool and i got some errors regarding libsc6 version, i updated the question with the error log. Could this mean libsc6 is a problem and needs to be updated or install a different version of it ?
    – XenoWad
    Aug 15 '15 at 11:32
  • In fact, libc6 is used by almost any software written in C, so it may cause a problem in many software if your libc6 library is not the one expected by all these software.
    – perror
    Aug 15 '15 at 13:21
  • So how can i ask what version is needed? Should i update it to the latest version? If not, will different software need different versions of libsc6? I am not even a novice with linux, i'm eager to learn and i am sincerely sorry if i ask stupid questions.
    – XenoWad
    Aug 15 '15 at 15:35
  • Simply use ldd on an executable. It will show if the executable is missing libraries.
    – perror
    Aug 15 '15 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.