4

I have been searching for days and can only find threads about the touchpad not working or not being enabled but it seems Kali cannot find it all. I have both Windows and Mint and the touchpad works out of the box on both of them.

I remember having this issue with my previous laptop which was a Sony Vaio, however i think the issue there was just the driver wasn't installed.

Can anyone help me with this i have come to an end and cannot find anything at all

Output of "xinput -- list": http://pastebin.com/4wUcdG9b

I do have a USB mouse plugged in aswell at the moment so thats why it has usb optical mouse

4

Enter BIOS,

look for "Touchpad",

change "Advanced" to "Basic",

save and reboot.

3

I looked up on the bios touchpad settings as the answer suggested and there was a legend specifying that i2c module is needed to use advanced settings. Searching for the module i found this post: https://ubuntuforums.org/showthread.php?t=2244174

So you basically need to install i2c tools:

sudo apt-get install i2c-tools
1

As sudo or root run the following command line:

egrep -i 'synap|alps|etps' /proc/bus/input/devices

If you have the output somthing like:

N: Name="SynPS/2 Synaptics Touchpad"

If not, you need to install synaptic-touchpad from package manager

Edit /usr/share/X11/xorg.conf.d/50-synaptics.conf

nano /usr/share/X11/xorg.conf.d/50-synaptics.conf

you must have

Section "InputClass"
     Identifier "touchpad catchall"
     Driver "synaptics"
     MatchIsTouchpad "on"
     Option "TapButton1" "1"
     Option "VertEdgeScroll" "1"
End Section

add missing line

ctrl + o and enter (to save)

ctrl + x

Reboot

0

After 3 years of trying to fix this issue i finally found a solution. The problem is that there are too many touchpad drivers installed.

Here is how you fix it and force your touchpad into working again.

first type in the following command on your terminal:

cd /usr/share/X11/xorg.conf.d/ ; ls -la

you will see that there is more than one file in there. The important file is something similar to : 90-libinput.conf

These are your touch pad driver configuration files and each file is associated with a different touchpad driver.

In order for your touchpad to work you must uninstall every driver except libinput.

To quickly find all the drivers and remove them type in on your terminal

sudo apt-get remove xserver-xorg-input-

using tab completion will display all your drivers"

after the -input- enter in the driver name. Valid names would be:

xserver-xorg-input-synaptics

Its important that you DO NOT REMOVE ANYTHING WITH LIBINPUT OR THE WORDS "CORE"

once you have removed unused drivers remove all files from /usr/share/X11/xorg.conf.d/ except for the file containing the words libinput

to do this type in the following (safe) command:

sudo rm -rfi /usr/share/X11/xorg.conf.d/*

you will be asked to type yes or no to delete the files. type no when asked about libinput

now you just need to copy the libinput config file to the xorg.conf.d/ directory in etc. the following commands will do it for you:

sudo rm -rf /etc/X11/xorg.conf.d/* 
sudo cp /usr/share/X11/xorg.conf.d/*libinput* /etc/X11/xorg.conf.d/

reboot the system and now your touchpad works again:

   sudo poweroff

If this doesn't work it could be because you dont have libinput installed to get it type in this:

sudo apt-get install xserver-xorg-input-libinput -y

Took forever but it worked for me on debian linux mint My laptop is a toshiba c55 GUI options work after doing this

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.