0

I am using Arch Linux and have UTF-8 encoding enabled. But how can I display a unicode character in ncmpcpp via the config file of ncmpcpp?

I already added the line filesystem_charset "UTF-8" to /etc/mpd.conf, which I think is unnecessary.

In the ~/.ncmpcpp/config file, I tried progressbar_look = "\u25BA" but it spits out all the characters as they are. Also tried setting

system_encoding = "utf8"

in ~/.ncmpcpp/config but doesn't seem to work. BTW, I can print unicode on the terminal. I'm using xfce4-terminal if that helps.

1

You can just enter ► directly in the config file, without any escaping. Note that the progressbar_look setting must contain exactly two or three characters.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.