Kali Linux 2.0 released with awesome UI and performance.
Today I installed Kali Linux 2.0 after installing updates I installed Google Chrome. Now The problem is that I cannot access chrome command property in Kali Linux 2.0 nor in the Top Bar nor in the Dash to Dock . The Kali Dev team have changed the simple gnome to gnome 3.14. In early versions of Kali we right click on an application in Top bar and select property. where we were changing command.


I need this for chrome because I want to run google-chrome as standard user while logged in as root. I have created a user for chrome using....

useradd -m chromeuser

Now whenever i want to run chrome as standard user while logged in as root I run.

gksu -u chromeuser google-chrome

I want to add this line to chrome property command .

My question is is there any way to modify application shortcut property in Kali Linux 2.0 (Gnome 3.14.1) using CLI?


First install the Gnome tools here the command to install

sudo apt-get install --no-install-recommends gnome-panel

And then use this command it will create a launcher on desktop

gnome-desktop-item-edit /root/Desktop --create-new

Well, you have 2 options:

  1. Edit the GNOME menu: In newer version of GNOME, the menu editor (i.e. Alacarte) was hidden, launch it by alacarte. Note that you shouldn't blame Kali's devs for this, because this is GNOME design and they repect that (and the GNOME Flashback you used to use got dropped a long time ago, you might want to try GNOME Classic instead).

  2. Edit the launcher: Google Chrome launcher could be either one of these (I'm not using it so not sure which is the one):




Open with your favorite text editor and change google-chrome to gksu -u chromeuser google-chrome

  • "alacarte" Worked for me. Thanks
    – Habibullah
    Aug 16 '15 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.