1

I have recently installed debian 8 with xfce 4.10, and I am annoyed by the following:

Menus (like e.g. the one that pops up if I press ctrl-esc) overrides the access to short cuts.

Normally I have that the short cut ctrl-alt-t opens a terminal, but if I press ctrl-esc and then this sequence when the menu is still open then nothing happens.

Other menus that block the short cuts are the roll-down menus from the panels, and even sometimes when parts of the panel is in focus.

Question: Is there a way to force short cut keys to always work?

  • You're right about that. It blocks keyboard shortcuts when the Applications Menu is open on both the desktop context menu and if it is a panel item. I have noticed however that the Whisker Menu does not block keyboard shortcuts. packages.debian.org/jessie/xfce4-whiskermenu-plugin – jbrock Aug 13 '15 at 18:42
  • I tried to install the whiskermenu package, but nothing happened - do I need to configure something somewhere? – Thomas Kragh Aug 16 '15 at 17:16
  • It should be in the Debian repository. You can install by the following in terminal: sudo apt-get install xfce4-whiskermenu-plugin – jbrock Aug 16 '15 at 18:48
  • Then you would just add it to a panel. Panel Preferences > Items To apply a keyboard shortcut for the menu to pop up, the command is: xfce4-popup-whiskermenu – jbrock Aug 16 '15 at 18:51
  • It is better to install packages from repositories when available than installing a deb package. This way you get updates to the programs when you update your system. – jbrock Aug 16 '15 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.