2

The overarching question:

  • How can I enable SDDM to accept username input in Debian?

Underlying/implicit questions:

  • How does SDDM recognize users?
  • What is the Debian alternative to /etc/sddm.conf ?

Namely,on LDAP/Kereberos clients with Debian Jessie, sometimes the SDDM login screen provides a list of all LDAP users for login - sometimes not.

I.e., How can I change the login screen for SDDM to allow input of username and validate with LDAP/Kereberos?

  • Change ssdm theme ej elarum , apt-get install sddm-theme-elarum – Maxnux Aabb Sep 13 '17 at 13:47
4
+50

I've seen similar issues with gdm.

The problem is not directly related to SDDM, it is related to a combination of the fact that LDAP users are unknown until we have access to the LDAP server, the fact that systemd was made the default init system in Debian Jessie (which adds massive parallellisation to startup) and the fact that, by default, there is no obvious dependency between SDDM and LDAP.

To be precise, if you want SDDM to show usernames, then the usernames need to already be known by the time SDDM starts up. For that, the system needs to have a working nsswitch database, which if you're using LDAP means it needs to have a working network connection. That dependency does not exist as shipped.

If you want it, you need to add it yourself. There are two ways of doing that:

  1. Add $network to the Required-Start: header in the SDDM init script. This adds the dependency for whatever init system you use.
  2. Copy sddm.service from /lib/systemd/system to /etc/systemd/system, and add a line After=network.target to the [Unit] section. This is systemd-specific.

Next time you reboot, SDDM should have all the users listed.

  • Great answer! Also though - is there anyway to not have sddm show user logins? – Donnied Aug 17 '15 at 17:20
  • Not sure about that. I know that gdm has the ability to disable that by changing themes, but I don't actually use sddm myself, so I couldn't tell you. – Wouter Verhelst Aug 21 '15 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.