2

Though I have the feeling the answer might be already out there, after reading several questions I did not manage to solve my problem. Apologies in advance in case of duplication.

Current Situation: I have 1 screen detached I cannot manage to take control of:

There is a screen on:
        9667.pts-11.compute-2-1 (Detached)
1 Socket in /var/run/screen/S-pan.

Whenever I do screen -r, -R, -d -r, -D -RR, the ssh session gets stuck and not responsive.

Question: I am looking for a method to clear the screen list (I am not particularly interested in recovering that screen).

Any help is highly appreciated.

  • To complete the case: Now I started a new screen and I have two screens in the list. I can attach and detach the new screen without any problem. However, the old screen (the one in the question) is still not accessible. – GioPan Aug 11 '15 at 10:25
  • The system gets stuck and you have to reboot? That sounds like a hardware / driver problem. No matter how badly confused screen is, you should be able to kill it from another ssh session, or local terminal window / text console. – Peter Cordes Aug 11 '15 at 19:08
  • Maybe my explanation was not completely correct and descriptive. What actually happened was: 1) I connected to the machine through an ssh session, 2) I tried to recover the detached screen session through 'screen -r' or the like (see the question) 3) the ssh session became not responsive to command line instructions and keyboard shortcuts such as 'CTRL-c' or 'CTRL-x', 4) I closed the ssh session and started a new one to take control of the machine again. I edited the question to remove "reboot" – GioPan Aug 13 '15 at 6:51
2

If you just want to get rid of this screen session , you can do:

kill 9667; screen -wipe

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.