3

My notebook had windows 10 and ubuntu 15.04 in dual boot in uefi mode. Then I tried to replace ubuntu by fedora 22. Ubuntu boot loader was installed in /boot/efi, but I formatted that partition when I was installing fedora. Now I was unable to access windows but its files are all current installed. Is there anyway to make fedora recognize windows or recovery the windows boot loader?

I tried Boot-Repair by using a bootable iso of ubuntu, but I get the following message "GPT detected. Please create a BIOS-Boot partition” error when using boot-repair".

Then I tried to edit the /etc/grub.d/40_custom by adding this entry:

menuentry 'Microsoft Windows 10' {
    set root='hd1,gpt'
    chainloader \\EFI\\Microsoft\\Boot\\bootmgfw.efi
    boot
 }

and running grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg. But it did not work.

Could anyone help?

Thanks.

The output of the command efibootmgr -v is:

BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0003,0004,000B,000C,0007,0001,0005,0006
Boot0001* UEFI:CD/DVD Drive BBS(129,,0x0)
Boot0002* Fedora    HD(1,GPT,03c2bf33-6dd6-4795-b409-ec77b3f6a7cf,0x800,0x32000)/File(\EFI\fedora\shim.efi)
Boot0003* Fedora    HD(1,GPT,03c2bf33-6dd6-4795-b409-ec77b3f6a7cf,0x800,0x32000)/File(\EFI\FEDORA\shim.efi)
Boot0004* Windows Boot Manager  HD(1,GPT,03c2bf33-6dd6-4795-b409-ec77b3f6a7cf,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)
Boot0005* UEFI:Removable Device BBS(130,,0x0)
Boot0006* UEFI:Network Device   BBS(131,,0x0)
Boot0007* Windows 10    VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot000B* UEFI OS   HD(1,GPT,03c2bf33-6dd6-4795-b409-ec77b3f6a7cf,0x800,0x32000)/File(\EFI\BOOT\BOOTX64.EFI)
Boot000C* UEFI: KingstonDT 101 G2 PMAP  PciRoot(0x0)/Pci(0x1d,0x0)/USB(1,0)/USB(3,0)..BO
  • Why did grub2-mkconfig not work? Did you get an error message you could add to your post? What folders can you see below /boot/efi/EFI/? – Roflo Aug 11 '15 at 15:59
  • A couple of notes from the last time I fiddled with GRUB: 1) I used forward-slashes in chainloader; ie: chainloader /EFI/Microsoft/Boot/bootmgfw.efi; don't know if that's an issue. 2) I had several copies of grub.cfg files, but the real one was at /etc/gruf2-efi.cfg. Hope it helps. – Roflo Aug 11 '15 at 16:05
  • @Roflo, grub2-mkconfig worked. It added the windows entry to grub.cfg. I ran 'grub2-probe --target=hints_string /boot/efi/EFI/Boot/bootmgfw.efi'. The output was: '--hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1'. Then I changed chainloader to '/boot/efi/EFI/Boot/bootmgfw.efi' and 'set root' to: set root(hd0,gpt1) and I ran grub2-mkconfig again. After restart, when I choose to boot in windows I get these errors: 'error hd0 not found' and 'error: you need to load the kernel first.'. – user91655 Aug 11 '15 at 17:55
2

The easier way might be to "restore" windows and then install fedora. (Regarding shared ESP and the fact that some distros are easy at formatting the already existing one, that's why I didn't go for the "shared" one and ALT Linux makes a separate EFI System Partition just in case...) If you want to have extended fun anyways, read http://www.rodsbooks.com/efi-bootloaders/principles.html and get win10's typical /boot/efi contents from some other system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.