3

One day when booting my computer it froze at the Linux Mint logo. I pressed ESC and i noticed that it failed to start the mdm. I tried reinstalling from the command line but it did not work. I eventually bypassed the problem installing lightdm and then kdm, and now my system boots fine. But when i tried to open GIMP, i didn't find it. Trying to install it gives me the same error as when i tried to install mdm.

$ sudo apt-get install gimp

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gimp : Depends: libwebkitgtk-1.0-0 (>= 1.3.10) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

This is what i already tried:

sudo apt-get clean && sudo apt-get update

sudo apt-get upgrade

apt-get install -f

sudo dpkg --configure -a 

sudo apt-get dist-upgrade

The last one made somewhat of a difference as it made the user graphic interface somewhat like it used to be before i had any problems. I then installed synaptic and tried to Fix Broken Package without much luck. This is the error i get:

E: Unable to correct problems, you have held broken packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

I also tried to remove and reinstall both mdm and GIMP, but it said the were not installed when trying to remove them. I did the same with libwebkitgtk-1.0-0 and any other package down the dependency tree. libwebkitgtk-1.0-0 leads to libharfbuzz0a which lead to libpangoft2-1.0-0 which it says is already installed. libharfbuzz0a is the only packaged i succeed in removing, but of course i can't reinstall it.

After the distro update i have Linux Mint 17 Qiana, and before i had Petra

I suspect there is an issues with the repositories, but i wait your judgments.

Thank you in advance, i hope to have not put too much useless information.

1

Looking at this answer https://askubuntu.com/questions/616807/cannot-install-gimp-64-bit i solved the problem changing the mirrors. Now everything works perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.