1

This question is an exact duplicate of:

Today I installed Kali Linux via bootable USB, and during installation there was a problem installing the bootloader. So I skipped its installation and restarted my computer. But GRUB couldn't find the Kali Linux installed on my logical partition sda4, i.e., it didn't show the option to boot to Kali Linux.

Moreover, during my installation, I set the bootable flag as "no", and I don't know whether it will have any effect on the boot.

I have presently three operating systems installed on other partitions (Windows 7, Linux Mint 17, and Linux Mint 17.2) and today Kali.  Installation was also completed.

So how do I boot to Kali Linux now??

This is the result after I tried the command sudo update-grub:

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.18.2-031802-generic
Found initrd image: /boot/initrd.img-3.18.2-031802-generic
Found linux image: /boot/vmlinuz-3.13.0-24-generic
Found initrd image: /boot/initrd.img-3.13.0-24-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
 No volume groups found
Found Windows 7 (loader) on /dev/sda1
Found Linux Mint 17 Qiana (17) on /dev/sda7
done

marked as duplicate by John, RalfFriedl, G-Man, Isaac, filbranden Nov 25 '18 at 4:49

This question was marked as an exact duplicate of an existing question.

  • Have you tried sudo update-grub from one of your Linux-Mint systems? – Qeole Aug 10 '15 at 14:55
  • no but going to do that now @Qeole – Jasser Aug 10 '15 at 15:01
  • @Qeole I have edited the question – Jasser Aug 10 '15 at 15:10