0

I tried playing around with compiling my own kernel. Everything is fine so far, except for that one thing.

Whenever I leave a wifi network or unplug my ethernet cable the system does not recognize, that the connection was lost and I have to manually tell the network manager.

I think it has to do with the new kernel, since that is the only thing that changed.

Since I feel like the documentation on the kernel components is pretty hard to parse, I'll ask it:

What kernel module/symbol did I set wrongly to provoke this behaviour?

1 Answer 1

2

My particular problem turned out to be ifplugd. It failed with a NLAPI: Packet too small or truncated error everytime I plugged my ethernet cable in or out.

Seems like some change in Kernel 3.9 introduced something. So I recompiled ifplugd with a change to the buffer size in src/nlapi.c line 74.

-- char replybuf[1024];
++ char replybuf[8*1024];

Now it works.

Related links:

2
  • Have you filed a bug? Commented Aug 11, 2015 at 10:04
  • The bug is already filed here: bugs.debian.org/cgi-bin/bugreport.cgi?bug=704495 The code seems to have changed since then without fixing the problem, that's why I omitted the link, but for completeness sake, it should be there.
    – Minix
    Commented Aug 11, 2015 at 11:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .