1

Sound plays (drum roll) at login screen. In Ubuntu and Xubuntu XFCE no sound emits from the laptop speaker, but does from the external speakers. Pulseaudio panel monitor bar dances with the sound.... but nothing heard.

A number of tests have been carried out, as listed below, and in the comments of Answer 1. As yet nobody has come up with a method of establishing how to direct the sound to the internal speaker.

Ubuntu MutiMedia forum suggests asking here, as nobody there can identify the correct procedure to rectify this problem All tests have been logged on that forum.

I'm running Ubuntu 12.04 LTS.

Here's the Alsa info script log: http://www.alsa-project.org/db/?f=77747dc55bb07c3ef222dec15332bd35d5ab9aaf

Ran:

$ echo autospawn = no >> ~/.config/pulse/client.conf  #use ~/.pulse/client.conf on Ubuntu <= 12.10
$ killall pulseaudio
$ LANG=C pulseaudio -vvvv --log-time=1 > ~/pulseverbose.log 2>&1

Output: http://filebin.ca/2BYEAFV6WLpi/pulseverbosecopy.log

Ran:

$ pacmd
No PulseAudio daemon running, or not running as session daemon.
$ rm -r ~/.pulse*; pulseaudio -k
E: [pulseaudio] main.c: Failed to kill daemon: No such process

Other test logs:

pastebin.com/3nhedfx6
pastebin.com/4UVxCJXM
pastebin.com/XxbSDvRR

Perhaps if we could establish the sound setup at the login screen, we would see how it should be configured.

Can anybody help?

  • Thank you Gilles, for adding the direct link to the pulseverbose.log – Marco-UandL Aug 10 '15 at 0:04
0

I don't suggest purging the pulseaudio package. You could remove it's files and then re-install it, if you really want to try that.

Things to check:

psg () { ps u -p $(pgrep "${@:--u$USER}");  }  # define a handy function

psg pulse   # see if there is a pulseaudio process running

cat /proc/asound/card0/pcm0p/sub0/hw_params 
  # see if anything in your system has the sound device open

lsof /dev/snd/pcmC0D0p
  # see what has the sound device open

pavucontrol   # a pulseaudio config gui

These commands are all checking the first PCM playback stream of alsa card0. This is the HDA-Intel analog output, which is almost certainly what's hooked up to your speakers.

Actually, hmm, I'm not 100% sure your system has card0 as the analog out. It looks like card0 is your HDMI output, and card1 is

Card hw:1 'SB'/'HDA ATI SB at 0xd0440000 irq 16'

Try playing something back through card1. e.g.

aplay -L  # choose a "device string"
aplay -vv -D hw:CARD=HDMI,DEV=3 foo.wav
# vs.
aplay -vv -D hw:CARD=PCH,DEV=0 foo.wav

Device sub-numbers may be different on your system.

These direct hw: devices are what pulseaudio uses as a backend. If pulseaudio has the alsa hw device open, aplay won't be able to use it directly, only through dmix:CARD=PCH,DEV=0 or similar (dmix: devices actually send data to pulseaudio to allow sharing, not directly to the device.)

-D default is alsa default that presumably your pulseaudio is set up to use. PA is configurable, though. If you need to, you can change its default output to the one that actually makes noise with aplay.

Sorry I didn't dig through all the stuff you said you tried, so some of this may be redundant.

One great thing about Linux is that when the high-level frontend stuff gets more confusing rather than less, or seems over-complicated, it's usually easy to poke around under the hood. :) (dbus / systemd are exceptions to this, though.)

  • Thanks Peter... purge was just something to try. I'll work through your list. TO CLARIFY: the laptop has only one jack output, to headphones. – Marco-UandL Aug 12 '15 at 12:33
  • The headphone jack can feed the ext speakers.... it always emits sound, even when the two config options are tried 'headphones' & 'speakers'. Is config confused.... does it think 'speakers' are on an ext jack output. IE. Login sees the int. speaker, but desktop doesn't. it would explain why choosing speakers, still channels sound through the headphone jack. Perhaps there should be 3 config options: Int speaker, speakers, headphones. – Marco-UandL Aug 12 '15 at 12:43
  • pastebin.com/3nhedfx6 The above lists all the tests..... there are a lot of them. to get many to work, I had to change dirs and names, but everything is documented. Phew! – Marco-UandL Aug 12 '15 at 17:36
  • @Marco-UandL: Ok, looks like pulse is already set up to play through the analog-out PCM device, and it's card1 (SB), dev=0. Maybe there's a mixer setting (alsamixer) to unmute the speakers, instead of just the headphones. Try unmuting and turning up the volume on everything in alsamixer. (Make sure it's controlling the correct card, by looking in the top left.) – Peter Cordes Aug 13 '15 at 1:55
  • Downloaded gnome-alsamixer. Here are the results. Sadly no success as yet, but 'eliminating possibles' is good. pastebin.com/4UVxCJXM – Marco-UandL Aug 13 '15 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.