My Manjaro Linux laptop suddenly won’t boot up my Xfce desktop environment. When I start the computer, the PC:

  1. boots pass GRUB, then
  2. quickly flashes this message:

    [0.029878] Ignoring BGRT: invalid status 0 (expected 1)
    starting version 222


  3. loads the usual cryptManjaro login screen to access my encrypted volume, because when I installed Manjaro, I encrypted the volume. However, once I enter my password,
  4. the screen goes completely black forever. No response. No sign of life. Every time I boot, I get stuck right after I enter my volume’s password.

What I’ve tried to do: When I boot up to the cryptManjaro login screen, I can press Alt+1 to get into a TTY that allows me to enter my cryptManjaro volume password. Once I enter the password, the PC loads a CLI, where I can login as root or my usual user. As root, I can

# startxfce4

to boot the root user’s Xfce desktop environment… but some features seem to be gone. I don’t get the Xfce bar at the bottom of the screen. Even from that environment as root I cannot connect to Wi-Fi. And when the computer screen goes black to save power, touching the keys or touch pad does NOT bring it back to life. Maybe there’s an error with the display manager? I had it disabled.

Back to the TTY (after I’ve pressed Alt+1): If I logged in as my usual user instead of root and then do

$ startxfce4

I get this error:

Fatal server error:
(EE) xf86Openconsole: Cannot open /dev/tty0 (No such file or directory)
Please consult the The X.Org Foundation support
at http://wiki.x.org for help.
(EE) Please also check the log file at "/home/xor/.local/share/xorg/Xorg.0.log for additional information.
(EE) Server terminated with error (1) Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

I can do

$ sudo startxfce4

but it gets the same result as

# startxfce4

so I cannot access the desktop environment of my usual user.

I’ve also tried from my normal user's TTY to

$ sudo pacman -Syyu

to check for any errors; but I can’t access the Internet, even when an Ethernet cable is plugged in. It may help to connect to the Internet, but I don't know how to connect in that environment. Manjaro didn't seem to load what it needs to sudo ping google.com.

Possible Causes For This Error?:

  1. I wonder if I have to add my user rights to /dev/tty0 because the error said,

    (EE) xf86Openconsole: Cannot open /dev/tty0 (No such file or directory)

    I wonder if my usual user rights to files that are necessary to boot have changed somehow.

  2. I don’t know if this would cause this error, but the first time I booted up my laptop to encounter this error, I closed the lid and reopened it while it was booting… would this damage the boot process somehow? If so, how can I fix it?

  3. Right before I turned off this computer I just installed VeraCrypt from the AUR.

My system info:

  • Laptop: HP ENVY TS 15 Notebook PC (With UEFI)


  • Card: Advanced Micro Devices [AMD/ATI] Richland [Radeon HD 8650G]
  • Display Server: X.org 1.17.2
  • driver: Radeon
  • tty size: 240×67
  • as startxfce4 is just a script using startx instead – McSinyx Aug 12 '15 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.