2

I have a Presonus AudioBox USB device, connected to a USB 3 port, that supports both MIDI and Audio input. When I launch JACK and open the connection list from QJackCtl, I can see that the AudioBox device itself is detected, because I can see the MIDI input. However the audio line-in input is not detected. If I open Audacity without JACK running, the audio input is available in the input device list. I've verified that I can record signal from my guitar through the AudioBox's line-in in Audacity.

What this tells me is that the device is working correctly, and seems to be detected by ALSA, but for some reason it is not being detected by JACK?

Does anyone have any idea what possible causes of this might be?

  • In case it matters, I've tried this on elementaryOS Freya and on Korora 22, both had the same issue. I also tried KXStudio 14.04.2, which showed several hw devices in Audacity, but I couldn't seem to record any of them, while JACK still didn't see the line-in. – Nick W. Aug 9 '15 at 0:31
  • Jack typically opens only a single sound card. Didn't you configure it to use the Presonus? – CL. Aug 9 '15 at 6:39
  • Good thought, thanks for commenting, but that's not the issue. I've tried using the (default) setting for the interface as well as setting it to the USB device specifically, got same result either way. Tried AVLinux as well for good measure, but had the same problem. – Nick W. Aug 11 '15 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.