0

So I'm trying to install this theme onto my laptop along side dash-to-dock (dash-to-dock works fine). I can't, however, get the theme to work on my user account. It works on the root account, but I would rather not use that for day-to-day use for obvious reasons. I've tried doing everything with sudo, restarting the shell after installation, and rebooting but it refuses to work. It does appear in gnome-tweak-tool but selecting the theme does not apply it like it does on the root account; gnome-tweak-tool is being run with sudo.

gsettings set org.gnome.desktop.interface gtk-theme <theme>
gsettings set org.gnome.desktop.wm.preferences theme <theme>

does not fix it either

gnome-tweak-tool shows that I have selected that theme even after rebooting, so it is clearly changing something. However, screenfetch shows the GTK theme as Adwaita - the default.

It just seems odd that it works fine on the root user but not on the admin user account while using sudo.

GNOME version 3.16.3

Kernel: i686 Linux 4.1.4-1-ARCH

1

Well, this is weird, I did what don_crissti said and ran 'gsettings get org.gnome.desktop.interface gtk-theme' which printed 'Adwaita' as expected. But after that, I ran 'gsettings set org.gnome.desktop.interface gtk-theme Arc-Darker which now works. After a restart, which I had already tried before.

Thanks for helping

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.