2

I've been trying to install R on a remote machine using command line. The machine characteristics are

uname -a
Linux ###### 2.6.32-71.40.1.el6.x86_64 #1 SMP Tue Jul 3 14:39:16 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a
LSB Version:    :core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Distributor ID: RedHatEnterpriseServer
Description:    Red Hat Enterprise Linux Server release 6.0 (Santiago)
Release:        6.0
Codename:       Santiago

I have installed everything but there seems to be a problem in libjpeg.so.62. If I run R installation as:

sudo yum install R

Loaded plugins: rhnplugin
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package R.x86_64 0:3.2.1-2.el6 set to be updated
--> Processing Dependency: libRmath-devel = 3.2.1-2.el6 for package: R-3.2.1-2.el6.x86_64
--> Processing Dependency: R-java = 3.2.1-2.el6 for package: R-3.2.1-2.el6.x86_64
--> Processing Dependency: R-devel = 3.2.1-2.el6 for package: R-3.2.1-2.el6.x86_64
--> Running transaction check
---> Package R-devel.x86_64 0:3.2.1-2.el6 set to be updated
--> Processing Dependency: R-java-devel = 3.2.1-2.el6 for package: R-devel-3.2.1-2.el6.x86_64
--> Processing Dependency: R-core-devel = 3.2.1-2.el6 for package: R-devel-3.2.1-2.el6.x86_64
---> Package R-java.x86_64 0:3.2.1-2.el6 set to be updated
--> Processing Dependency: R-core = 3.2.1-2.el6 for package: R-java-3.2.1-2.el6.x86_64
---> Package libRmath-devel.x86_64 0:3.2.1-2.el6 set to be updated
--> Processing Dependency: libRmath = 3.2.1-2.el6 for package: libRmath-devel-3.2.1-2.el6.x86_64
--> Running transaction check
---> Package R-core.x86_64 0:3.2.1-2.el6 set to be updated
--> Processing Dependency: tex(latex) for package: R-core-3.2.1-2.el6.x86_64
--> Processing Dependency: tex(dvips) for package: R-core-3.2.1-2.el6.x86_64
--> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2)(64bit) for package: R-core-3.2.1-2.el6.x86_64
--> Processing Dependency: cups for package: R-core-3.2.1-2.el6.x86_64
--> Processing Dependency: libtk8.5.so()(64bit) for package: R-core-3.2.1-2.el6.x86_64
--> Processing Dependency: libtcl8.5.so()(64bit) for package: R-core-3.2.1-2.el6.x86_64
--> Processing Dependency: libXt.so.6()(64bit) for package: R-core-3.2.1-2.el6.x86_64
--> Processing Dependency: libXmu.so.6()(64bit) for package: R-core-3.2.1-2.el6.x86_64
---> Package R-core-devel.x86_64 0:3.2.1-2.el6 set to be updated
--> Processing Dependency: zlib-devel for package: R-core-devel-3.2.1-2.el6.x86_64
--> Processing Dependency: xz-devel for package: R-core-devel-3.2.1-2.el6.x86_64
--> Processing Dependency: tk-devel for package: R-core-devel-3.2.1-2.el6.x86_64
--> Processing Dependency: tcl-devel for package: R-core-devel-3.2.1-2.el6.x86_64
--> Processing Dependency: pcre-devel for package: R-core-devel-3.2.1-2.el6.x86_64
--> Processing Dependency: libX11-devel for package: R-core-devel-3.2.1-2.el6.x86_64
--> Processing Dependency: gcc-c++ for package: R-core-devel-3.2.1-2.el6.x86_64
--> Processing Dependency: bzip2-devel for package: R-core-devel-3.2.1-2.el6.x86_64
---> Package R-java-devel.x86_64 0:3.2.1-2.el6 set to be updated
--> Processing Dependency: java-devel for package: R-java-devel-3.2.1-2.el6.x86_64
---> Package libRmath.x86_64 0:3.2.1-2.el6 set to be updated
--> Running transaction check
---> Package R-core.x86_64 0:3.2.1-2.el6 set to be updated
--> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2)(64bit) for package: R-core-3.2.1-2.el6.x86_64
---> Package bzip2-devel.x86_64 0:1.0.5-7.el6_0 set to be updated
---> Package cups.x86_64 1:1.4.2-35.el6_0.1 set to be updated
--> Processing Dependency: portreserve for package: 1:cups-1.4.2-35.el6_0.1.x86_64
--> Processing Dependency: poppler-utils for package: 1:cups-1.4.2-35.el6_0.1.x86_64
---> Package gcc-c++.x86_64 0:4.4.4-13.el6 set to be updated
--> Processing Dependency: libstdc++-devel = 4.4.4-13.el6 for package: gcc-c++-4.4.4-13.el6.x86_64
---> Package java-1.6.0-openjdk-devel.x86_64 1:1.6.0.0-1.39.b17.el6_0 set to be updated
---> Package libX11-devel.x86_64 0:1.3-2.el6 set to be updated
--> Processing Dependency: pkgconfig(xcb) >= 1.1.92 for package: libX11-devel-1.3-2.el6.x86_64
--> Processing Dependency: pkgconfig(xproto) for package: libX11-devel-1.3-2.el6.x86_64
--> Processing Dependency: pkgconfig(xcb) for package: libX11-devel-1.3-2.el6.x86_64
--> Processing Dependency: pkgconfig(kbproto) for package: libX11-devel-1.3-2.el6.x86_64
--> Processing Dependency: libXdmcp-devel for package: libX11-devel-1.3-2.el6.x86_64
--> Processing Dependency: libXau-devel for package: libX11-devel-1.3-2.el6.x86_64
---> Package libXmu.x86_64 0:1.0.5-1.el6 set to be updated
---> Package libXt.x86_64 0:1.0.7-1.el6 set to be updated
---> Package pcre-devel.x86_64 0:7.8-3.1.el6 set to be updated
---> Package tcl.x86_64 1:8.5.7-6.el6 set to be updated
---> Package tcl-devel.x86_64 1:8.5.7-6.el6 set to be updated
---> Package texlive-dvips.x86_64 0:2007-56.el6 set to be updated
--> Processing Dependency: psutils for package: texlive-dvips-2007-56.el6.x86_64
---> Package texlive-latex.x86_64 0:2007-56.el6 set to be updated
--> Processing Dependency: texlive-utils = 2007-56.el6 for package: texlive-latex-2007-56.el6.x86_64
--> Processing Dependency: texlive-texmf-latex = 2007 for package: texlive-latex-2007-56.el6.x86_64
--> Processing Dependency: netpbm-progs for package: texlive-latex-2007-56.el6.x86_64
---> Package tk.x86_64 1:8.5.7-5.el6 set to be updated
---> Package tk-devel.x86_64 1:8.5.7-5.el6 set to be updated
--> Processing Dependency: libXft-devel for package: 1:tk-devel-8.5.7-5.el6.x86_64
---> Package xz-devel.x86_64 0:4.999.9-0.3.beta.20091007git.el6 set to be updated
---> Package zlib-devel.x86_64 0:1.2.3-25.el6 set to be updated
--> Running transaction check
---> Package R-core.x86_64 0:3.2.1-2.el6 set to be updated
--> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2)(64bit) for package: R-core-3.2.1-2.el6.x86_64
---> Package libXau-devel.x86_64 0:1.0.5-1.el6 set to be updated
---> Package libXdmcp-devel.x86_64 0:1.0.3-1.el6 set to be updated
--> Processing Dependency: libXdmcp = 1.0.3-1.el6 for package: libXdmcp-devel-1.0.3-1.el6.x86_64
--> Processing Dependency: libXdmcp.so.6()(64bit) for package: libXdmcp-devel-1.0.3-1.el6.x86_64
---> Package libXft-devel.x86_64 0:2.1.13-4.1.el6 set to be updated
--> Processing Dependency: freetype-devel >= 2.1.9-2 for package: libXft-devel-2.1.13-4.1.el6.x86_64
--> Processing Dependency: fontconfig-devel >= 2.2-1 for package: libXft-devel-2.1.13-4.1.el6.x86_64
--> Processing Dependency: pkgconfig(xrender) for package: libXft-devel-2.1.13-4.1.el6.x86_64
--> Processing Dependency: pkgconfig(freetype2) for package: libXft-devel-2.1.13-4.1.el6.x86_64
--> Processing Dependency: pkgconfig(fontconfig) for package: libXft-devel-2.1.13-4.1.el6.x86_64
--> Processing Dependency: libXrender-devel for package: libXft-devel-2.1.13-4.1.el6.x86_64
---> Package libstdc++-devel.x86_64 0:4.4.4-13.el6 set to be updated
---> Package libxcb-devel.x86_64 0:1.5-1.el6 set to be updated
---> Package netpbm-progs.x86_64 0:10.47.05-11.el6 set to be updated
--> Processing Dependency: netpbm = 10.47.05-11.el6 for package: netpbm-progs-10.47.05-11.el6.x86_64
--> Processing Dependency: ghostscript for package: netpbm-progs-10.47.05-11.el6.x86_64
--> Processing Dependency: libnetpbm.so.10()(64bit) for package: netpbm-progs-10.47.05-11.el6.x86_64
---> Package poppler-utils.x86_64 0:0.12.4-3.el6_0.1 set to be updated
---> Package portreserve.x86_64 0:0.0.4-4.el6 set to be updated
---> Package psutils.x86_64 0:1.17-34.el6 set to be updated
---> Package texlive-texmf-latex.noarch 0:2007-35.el6 set to be updated
--> Processing Dependency: texlive-texmf-errata-latex = 2007 for package: texlive-texmf-latex-2007-35.el6.noarch
--> Processing Dependency: tex-preview for package: texlive-texmf-latex-2007-35.el6.noarch
---> Package texlive-utils.x86_64 0:2007-56.el6 set to be updated
---> Package xorg-x11-proto-devel.noarch 0:7.4-35.el6 set to be updated
--> Running transaction check
---> Package R-core.x86_64 0:3.2.1-2.el6 set to be updated
--> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2)(64bit) for package: R-core-3.2.1-2.el6.x86_64
---> Package fontconfig-devel.x86_64 0:2.8.0-3.el6 set to be updated
---> Package freetype-devel.x86_64 0:2.3.11-6.el6_0.2 set to be updated
---> Package ghostscript.x86_64 0:8.70-6.el6 set to be updated
--> Processing Dependency: urw-fonts >= 1.1 for package: ghostscript-8.70-6.el6.x86_64
--> Processing Dependency: ghostscript-fonts for package: ghostscript-8.70-6.el6.x86_64
---> Package libXdmcp.x86_64 0:1.0.3-1.el6 set to be updated
---> Package libXrender-devel.x86_64 0:0.9.5-1.el6 set to be updated
---> Package netpbm.x86_64 0:10.47.05-11.el6 set to be updated
---> Package tex-preview.noarch 0:11.85-10.el6 set to be updated
---> Package texlive-texmf-errata-latex.noarch 0:2007-7.1.el6 set to be updated
--> Running transaction check
---> Package R-core.x86_64 0:3.2.1-2.el6 set to be updated
--> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2)(64bit) for package: R-core-3.2.1-2.el6.x86_64
---> Package ghostscript-fonts.noarch 0:5.50-23.1.el6 set to be updated
--> Processing Dependency: xorg-x11-font-utils for package: ghostscript-fonts-5.50-23.1.el6.noarch
---> Package urw-fonts.noarch 0:2.4-10.el6 set to be updated
--> Running transaction check
---> Package R-core.x86_64 0:3.2.1-2.el6 set to be updated
--> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2)(64bit) for package: R-core-3.2.1-2.el6.x86_64
---> Package xorg-x11-font-utils.x86_64 1:7.2-10.el6 set to be updated
--> Processing Dependency: libfontenc.so.1()(64bit) for package: 1:xorg-x11-font-utils-7.2-10.el6.x86_64
--> Processing Dependency: libXfont.so.1()(64bit) for package: 1:xorg-x11-font-utils-7.2-10.el6.x86_64
--> Running transaction check
---> Package R-core.x86_64 0:3.2.1-2.el6 set to be updated
--> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2)(64bit) for package: R-core-3.2.1-2.el6.x86_64
---> Package libXfont.x86_64 0:1.4.1-1.el6 set to be updated
---> Package libfontenc.x86_64 0:1.0.5-2.el6 set to be updated
--> Finished Dependency Resolution
Error: Package: R-core-3.2.1-2.el6.x86_64 (epel)
           Requires: libjpeg.so.62(LIBJPEG_6.2)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

However if you go to the folder /usr/lib64/ there is a file named libjpeg.so.62 in it, so I would assume that libjpeg.so.62 is installed? What am I missing?

2
  • Are you using EPEL? – Wilf Aug 8 '15 at 10:34
  • Yes I think I'm using EPEL, by typing yum repolist it outputs epel Extra Packages for Enterprise Linux 6 - x86_64 11,746 (and some more repos) – Salami Aug 8 '15 at 10:44
2

On CentOS (similar to RHEL), libjpeg.so.62(LIBJPEG_6.2)(64bit) appears to be provided by the libjpeg-turbo package.

If it is available on your install (probably not if it could not be resolved), you should be able to install it with:

sudo yum install libjpeg-turbo

Otherwise, you could download the CentOS 6 package and install that - e.g. with:

wget http://mirror.ox.ac.uk/sites/mirror.centos.org/6/os/x86_64/Packages/libjpeg-turbo-1.2.1-3.el6_5.x86_64.rpm
sudo yum install libjpeg-turbo-1.2.1-3.el6_5.x86_64.rpm

Other package mirrors:

As a alternative, you could also add CentOS as a package source, but you shouldn't need to just for one package.

4
  • If you added the repo you probably need to add the GPG keys so it can check against them (you may also need it for some RPM files) – Wilf Aug 8 '15 at 14:24
  • When I do sudo yum install libjpeg-turbo it outputs No package libjpeg-turbo available and if I download the package and write sudo yum install libjpeg-turbo-1.2.1-3.el6_5.x86_64.rpm my terminal outputs warning: rpmts_HdrFromFdno: Header V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY Public key for libjpeg-turbo-1.2.1-3.el6_5.x86_64.rpm is not installed. Seems that I need a public key to install it... any ideas? – Salami Aug 8 '15 at 14:24
  • Not sure but (sudo) rpm --import http://eu-msync.centos.org/centos-6/6/os/x86_64/RPM-GPG-KEY-CentOS-6 may work – Wilf Aug 8 '15 at 14:29
  • @Sebas your welcome :) – Wilf Aug 8 '15 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.