4

I am using KDE on Debian Jessie.

Whenever I open an application, it appears on the first (left) screen. How do I change this?

This happens with most applications. For example Vuze opens correctly on the monitor it has been before, but Double Commander (doublecmd) which I use heavily doesn't.

If it matters I have 3 screens. Left: FullHD TV (HDMI) + middle: QHD monitor (DisplayPort) + right: FullHD laptop display.

  • Usually they open wherever your mouse is. Do you see something else? – user1794469 Aug 8 '15 at 5:35
  • 2
    That depends on the window manager or desktop envitonment you're using. Which one do you use? – Wouter Verhelst Aug 8 '15 at 5:43
  • @user1794469 e.g Vuze opens correctly on the monitor it has been before and e.g. Double Commander (doublecmd) which I use havily doesn't – LinuxSecurityFreak Aug 8 '15 at 6:19
  • @Wouter Verhelst I use KDE environment and window manager's name is KWin – LinuxSecurityFreak Aug 8 '15 at 6:19
  • @wouter-verhelst I'm using fluxbox. Of course it depends on the window manager but that didn't even occur to me as i think my other window manager does this as well. – user1794469 Aug 8 '15 at 7:03
0

I found that only a handful of applications, including Double Commander, does show up on the non-primary left screen, on which mouse cursor is not. That would suggest an error in those applications, rather than a problem with window manager settings. I will contact such developers.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.