0

I want to install Puppet 4.2 on a Ubuntu 14.04 Trusty and when installing puppetserver through apt-get I get the following error near the end of the installation:

dpkg: error processing archive /var/cache/apt/archives/puppet-agent_1.2.2-1trusty_amd64.deb (--unpack):
error setting ownership of `/etc/puppetlabs/code/environments/production/hieradata.dpkg-new': Operation not permitted

Afterwards when checking the service status it is listed as "puppetserver.dpkg-new" instead of simply puppetserver.

What's the problem? I run the apt-get with sudo.

  • Looks like a permission issue. What does ls -laR /etc/puppetlabs/code/environments/production/ show? – Faheem Mitha Aug 7 '15 at 14:59
  • Please show the full command of what you're trying to do. "I run the apt-get with sudo" isn't very clear. – Wouter Verhelst Aug 7 '15 at 15:02
  • Is that directory on some remote/external/FUSE filesystem? What's the output of df -T /etc/puppetlabs/code/environments/production? – Gilles Aug 8 '15 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.