0

I have installed Arch after Ubuntu and Elementary OS, and after that my grub was messed up, and I was unable to boot again in Elementary OS. So I decided to backup my files from home partition and to reinstall it.

I used BootRepair LiveCD, mounted /dev/sda3 (elementary partition) but than when I enter /mnt/home/$USER/ I see only directories, not files!

There are Desktop, Documents.. etc.. but when I enter those folders, it shows no files. I've tried ls -al, and many other options, tried to copy recursivly folder on some other location, but it would copy only directoryes.

  • Edit With Boot Repair, it repairs my grub, but only letting me to boot Ubuntu (sucessfuly indeed), elementary OS is not shown.. if I tried to manualy install grub on mounted elementary os via live cd I get it apear in grub, with bunch of old kernels and when I try it says no vmlinux image found... In mounted partition there is no vmlinux image also.. Here is report from Boot Repair, please someone help, I'm trying to fix this for more than 3 days and Im really starting to get desprerate :( paste.ubuntu.com/12024454 – fugitive Aug 7 '15 at 20:57
0

either the files have been deleted, or somehow another device got mounted OVER your original mount point.

Try displaying "/mnt/etc/fstab" for the original (elementary os) mounting information, and find out, from which partition "/home" originally came from.

Then mount this partition to somewhere else, if not already mounted and search from there.

Good luck ! Gerhard

  • This is what I get from /etc/fstab.. # / was on /dev/sda3 during installation UUID=6a80ea1e-b922-4b2a-a001-9d55912979e2 / ext4 errors=remount-ro 0 1 # swap was on /dev/sda2 during installation UUID=b2b6eac7-ad23-4fc7-8d9a-80ead7840802 none swap sw 0 0 I read a little about UID, and someone said, that your current UID must match OS that you've mounted to be able to access files.. But I don't know how to do it... – fugitive Aug 7 '15 at 11:26
  • you need to view /mnt/etc/fstab, which is (according to your original post) the place where you mounted the "elementary" partition. – gerhard d. Aug 7 '15 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.