The switch configured on the server (Centos 7) is configured as trunk for VLAN#115,2014. I have loaded

# lsmod | grep 8021q
# modprobe 8021q

I would like to configure an IP address on the server using the VLAN#115 Performing the following configuration:

ifcfg-em1

TYPE=Ethernet
BOOTPROTO=none
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME=em1
UUID=c0c4d851-d762-4301-8c20-d6128aee5261
DEVICE=em1
ONBOOT=yes

ifcfg-em1.115

TYPE=Ethernet
BOOTPROTO=none
IPADDR=172.31.141.242
PREFIX=24
GATEWAY=172.31.141.1
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME=em1.115
UUID=c0c4d851-d762-4301-8c20-d6128aee5261
DEVICE=em1.115
VLAN=yes
ONBOOT=yes

I ended up being not able to restart the network service. The error message appearing is :

Failed to start LSB: Bring up/down networking.

Could you please advise ? What am doing wrong ?

12 Answers 12

up vote 17 down vote accepted

it seems that disabling NetworkManager did the trick :)

systemctl stop NetworkManager
systemctl disable NetworkManager
  • Restarting it worked for me (didn't try restart, but using start instead of disable). – Skippy le Grand Gourou Dec 1 '15 at 10:31
  • you make my day! my VLAN and Bonding settings were not be able to start after server update and all because of the NetworkManager. – fuser Nov 25 '16 at 9:30
  • 1
    @iamsterdam it worked for me, but could you please elaborate why it works after disabling NetworkManager – Vishrant Jul 2 '17 at 17:13

Maybe a little late, but the problem in my case was that the UUID field of the two interfaces was the same, and they must be unique. Disabling NetworkManager does the trick, but the real solution would be changing/deleting the field. Leaving this here for future reference.

I was facing the same issue. Fortunately,

/etc/rc.d/init.d/network stop

gracefully stopped the network service. Then I did an:

ip addr flush dev <<dev-name>>

After that you can start the service, using either systemctl or /etc/rc.d/init.d/network start.

you need to add following in you file HWADDR="xx:xx:xx:xx:xx:xx" where xxxx is the real or cloned mac address of your interface card you can find by issuing command ifconfig -a.

IPV4_FAILURE_FATAL=no
IPV6INIT=yes"

Toggle the value-

IPV4_FAILURE_FATAL=yes
IPV6INIT=no # (if IPV6 not require)

Remove any additional ifcfg-Wiredconnection1 or -2 of the new adapters you have added on the server that are not used by the l2 or l3 network and restart. It will work.

This will solve the problem!

# rm /etc/udev/rules.d/70-persistent-ipoib.rules 

# reboot
  • Now edit /etc/sysconfig/network-scripts/ifcfg-eth0,
  • Add new HWADDR generated or remove it
  • Remove UUID line

-Restart the networking service

 #systemctl restart network.service

NOW! Working.

restart my machine and network service are not resolved this issue in my linux box.

I have removed the file /etc/sysconfig/network-scripts/ifcfg-eth0 and then recreated the file with different name ifcfg-eth1 with static ip details. After that I have started network service and it worked.

  1. Just comment #UUID

    ##UUID=XXXXX-XXXX-XXX-XXXXX
    
  2. Restart network

    sudo systemctl restart network
    

I had same problem with LSB in Centos and Ubunto on VMware. I solved it turn off Wifi on host (real machine) and turn on, and reboot the guest.

I had this error after importing a VM. The solution is to fix the HW address in the /etc/sysconfig/network-scripts/ifcfg-ens32 (ens32 happened to be my interface. You can check yours using Network Manager with nmtui)file.

Type 'ip addr' and note down the HW addr of your interface, for example 00:50:56:8d:6a:9e.Look up for the interface you are interested in from the list you get from 'ip addr'.

Open to edit your /etc/sysconfig/network-scripts/ifcfg-ens32 (change ifcfg-ens32 with your interface name, as said above get it from nmtui) and modify that address next to the key HWADDR.

Now: service network restart

Just stop and disable NetworkManager

And once again restart services it will be work

#systemctl stop NetworkManager
#systemctl disable NetworkManager

#service network restart
  • This is no different from the accepted answer (other than being badly formatted). Your answer should add some value such as explaining why disabling Network Manager fixes the problem and perhaps mention when it makes sense to do so. – Anthony Geoghegan Jun 15 '17 at 8:53

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.