2

I'm trying to install nginx 1.8 on Centos 7. I tried the following steps:

  1. Install nginx repo from http://nginx.org/en/linux_packages.html

    wget http://nginx.org/packages/centos/7/noarch/RPMS/nginx-release-centos-7-0.el7.ngx.noarch.rpm
    rpm -ivh nginx-release-centos-7-0.el7.ngx.noarch.rpm
    
  2. Install Nginx

    yum install nginx
    
  3. Start Nginx:

    sudo systemctl start nginx
    

But nothing happens; nginx doesn't start. The exact same steps work on Centos 6 without a problem.

Here is the output of systemctl status nginx:

nginx.service - The nginx HTTP and reverse proxy server
   Loaded: loaded (/usr/lib/systemd/system/nginx.service; enabled)
   Active: inactive (dead) since Thu 2015-08-06 14:30:51 UTC; 21s ago
  Process: 29865 ExecStop=/bin/kill -s QUIT $MAINPID (code=exited, status=0/SUCCESS)
 Main PID: 29776 (code=exited, status=0/SUCCESS)

Aug 06 13:31:12 vultr.guest systemd[1]: Failed to read PID from file /run/nginx.pid: Invalid argument
Aug 06 13:31:12 vultr.guest systemd[1]: Started The nginx HTTP and reverse proxy server.
Aug 06 13:31:30 vultr.guest systemd[1]: Started The nginx HTTP and reverse proxy server.
Aug 06 13:31:54 vultr.guest systemd[1]: Started The nginx HTTP and reverse proxy server.
Aug 06 13:31:57 vultr.guest systemd[1]: Started The nginx HTTP and reverse proxy server.
Aug 06 13:32:04 vultr.guest systemd[1]: Started The nginx HTTP and reverse proxy server.
Aug 06 14:30:20 vultr.guest systemd[1]: Started The nginx HTTP and reverse proxy server.
Aug 06 14:30:51 vultr.guest systemd[1]: Stopping The nginx HTTP and reverse proxy server...
Aug 06 14:30:51 vultr.guest systemd[1]: Stopped The nginx HTTP and reverse proxy server.
Aug 06 14:30:56 vultr.guest systemd[1]: Stopped The nginx HTTP and reverse proxy server.
0

Try these commands below

hostnamectl
hostnamectl set-hostname servername.domain.com
hostnamectl
systemctl restart sshd.service

rpm -Uvh http://nginx.org/packages/centos/7/noarch/RPMS/nginx-release-centos-7-0.el7.ngx.noarch.rpm

yum install nginx
systemctl enable nginx.service
systemctl start nginx.service

systemctl stop httpd.service  or systemctl disable httpd
yum remove httpd
systemctl disable httpd.service

systemctl enable nginx.service
systemctl start nginx.service

firewall-cmd --permanent --zone=public --add-service=http
firewall-cmd --permanent --zone=public --add-service=https
firewall-cmd --reload

http://your_server_IP_address/

  • this is not answering the question nor solving the described problem – Jakuje Aug 7 '15 at 14:23
  • There are a few things I'm not sure why they're included like restarting the ssh service, and this may not solve the problem, but it is actually a possible solution to the vague question in my opinion. – Julie Pelletier Jul 14 '16 at 2:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.