0

I just installed OpenSUSE on a dual boot setup with Windows, and it works absolutely perfectly. All devices work out of the box, except for the touchpad. Left-Clicking doesn't work but tapping does. I am not used to tapping all the time, because when I use the mouse, it is usually for dragging something, and pressing the left button while moving my finger along the touchpad is convenient.

This is the only problem I've faced so far with openSUSE, and this should be relatively easy to fix compared with my problems with other distros (e.g manjaro, elementary). I tried installing the xf86-input-synaptics package and the gsynaptics package but none worked. In fact, I noticed that gsynaptics logs that this feature isn't avaiable, skipping, and when I open it again, I notice nothing changes. I am using a Lenovo Z50-70 laptop.
Is there a fix or a module I could let the kernel load at boot time to fix this ?

0

From this answer, it seems fixed in the 3.16.7-24 kernel: https://forums.opensuse.org/showthread.php/504010-Lenovo-z5070-touchpad-problem

But that kernel is not (yet) in the official upgrade repo (still at 3.16.7-21).

  • Yes, I assume the kernel has to be the problem not the distro, so I am installing Tumbleweed at the moment. – Amr Ayman Aug 9 '15 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.