0

I run Arch Linux and did a complete pacman sync and upgrade of my entire system. One of the updates was a kernel upgrade that I am happy with and had no other problems with. One of the packages that was updated was Oracle VirtualBox 4.3 was upgraded to 5.0.

For the most part the upgrade seemed ok for VirtualBox, but there is this one VM running Windows 98 that never seems to be able to restore state, it gives some kind of error. I always have to discard the state and reboot. Googling this error turns up pretty much nothing, so I decided this 5.0 release isn't working out for me, I tried to downgrade.

An ls /var/cache/pacman/pkg | grep virtual will show me the following output.

virtualbox-4.3.20-3-x86_64.pkg.tar.xz
virtualbox-5.0.0-1-x86_64.pkg.tar.xz
virtualbox-host-modules-4.3.20-3-x86_64.pkg.tar.xz
virtualbox-host-modules-5.0.0-1-x86_64.pkg.tar.xz

So I do the pacman downgrade to 4.3 from my cache and it seems to work but the downgrade for the host modules fails. Apparently this tar contains the VirtualBox kernel modules that were compiled and packaged to the OLD kernel. The package manager site doesn't seem to have a 4.3 version of Oracle VirtualBox that is compiled to the NEW kernel so I am confused what to do at this point.

I thought about maybe trying to downgrade the kernel but when reading the intimidating instructions on how to do this on the Arch Wiki I decided it isn't worth the hassle. I would sooner just tear down and rebuild to a version of Linux that is less of a colossal PIA than Arch.

I then thought about possibly trying to download the VirtualBox kernel module sources for 4.3 and build them myself on my new kernel but for the life of me I can't seem to find the sources for download. I think I found their repository browser but it gives me a bunch of errors too, virtualbox.org must also be running on Arch.

enter image description here

I care a lot about this Windows 98 VM because I play a lot of my old computer games like Civilization II, which is important to me (Don't even mention that humanitarian tragedy that is Freeciv, it is not the same). Appreciate any thoughts or help you might have and keep in mind I am willing to do anything on this system just to get Oracle VirtualBox to work correctly.

  • Please include your new kernel version... – eyoung100 Aug 6 '15 at 4:32
  • @eyoung100 My apologies, I believe this is what pacman upgraded me to. It shows the hard depedency for virtualbox host modules here: archlinux.org/packages/core/x86_64/linux – maple_shaft Aug 6 '15 at 10:49
  • Then Virtualbox is not causing the problem. Use pacman -U to downgrade your kernel, and then downgrade VirtualBox. See Downgrading packages, specifically Section 2.2. Note that no chroot is needed, as you were able to boot – eyoung100 Aug 6 '15 at 17:38
  • @eyoung100 I downgraded my kernel to the version previous and it stated it was successful and found no conflicts, however when I rebooted it complained of failing to load kernel modules. I even used the downgrade which is supposed to be smart about finding dependencies by version and it reported no conflicts as well. The system seems to boot ok but then X11 fails to start correctly. I had to upgrade myself back to the new kernel to get things working again. Something is screwed up. If there were dependencies then pacman should be aware of them. Its this crap that makes people abandon linux. – maple_shaft Aug 7 '15 at 2:37
  • Before you "throw it out the Window" downgrade the kernel again, then tell us what's broken, and I'll help you... – eyoung100 Aug 7 '15 at 2:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.