2

On one of my computers with Xubuntu 10.04 there is a problem with the network connection. How can I debug it?

  • I tried the cable on my laptop (running the same operating system) and it worked, so it's not the cable
  • sudo dhclient and sudo /etc/init.d/networking restart don't help
  • sudo mii-tool -v outputs:

    no MII transceiver present

What else could be the problem? Is the network card broken?

7
  • Usually if the NIC is broken like this you start getting logs. Is there anything in dmesg or /var/log/*?
    – polynomial
    Oct 5 '11 at 7:11
  • @polynomial I can't see there nothing with network card.
    – xralf
    Oct 5 '11 at 9:41
  • If the NIC isn't built-in I might try it in another server, but all the testing you've done so far indicates the NIC is broken.
    – polynomial
    Oct 6 '11 at 3:07
  • It was working today for about half an hour.
    – xralf
    Oct 7 '11 at 11:05
  • @polynomial I will try to test it replacing the network card, which I will borrow, but I will bounty the question yet, because this knowledge could be useful (to detect broken network card)
    – xralf
    Oct 7 '11 at 11:07
3

Try ethtool instead - it should be able to get something from your network card even if there's no MII chip on the card.

3
+25

ethtool is the tool of choice here (give credit to Shadur), it'll let you know if you've got a link, and if you somehow got a half-duplex connection or some other misconfiguration.

If you don't see anything in the syslogs or in the output of dmesg, then you might be able to increase the debugging verbosity of the network driver. Try running modinfo -p e1000 (replace "e1000" with the name of the driver for your NIC). There might be an option you can give to modprobe (or put in a file in /etc/modprobe.d/) to increase the verbosity or debugging information.

Also, check out running tcpdump -i eth0 as root (replace "eth0" with your network device). You can see what kind of traffic you are getting, even with the interface unconfigured. You'll see stuff like broadcast or multicast traffic, and possibly your system's attempt to DHCP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.