0

Yesterday I updated my Arch Linux after 2 Months with sudo pacman -Syu and after the reboot I don't get any connection with the Internet neither from Browser nor with Skype, etc.

When I try to ping google.com I get

~]# ping google.com
ping: unkown host google.com

When I check the ethernet-connection:

ip link
1: .....
2: enps2o: ... state UP ...

and with ´ip addr´ i also see that I still have my regular IP addres.

After restarting the dhcp-service I got the same IP from the DHCP-server in our university, but still no internet connection. So I'll have a look to set up all my ethernet settings new, maybe there's something broken after the update.

After pulling out my ethernet-cable I had for about 2s connecting to the internet, but than it disconnected again

Here is the requested update log, and sorry I did the last update on the 15. of July so its only 2 Weeks away :)

[2015-07-15 09:42] [PACMAN] Running 'pacman -S banshee'
[2015-07-15 09:42] [ALPM] transaction started
[2015-07-15 09:42] [ALPM] installed libgdiplus (3.12-1)
[2015-07-15 09:42] [ALPM] installed mono (4.0.2.5-1)
[2015-07-15 09:42] [ALPM] installed gtk-sharp-2 (2.12.22-1)
[2015-07-15 09:42] [ALPM] installed mono-addins (1.1-1)
[2015-07-15 09:42] [ALPM] installed dbus-sharp (0.8.1-1)
[2015-07-15 09:42] [ALPM] installed dbus-sharp-glib (0.6.0-1)
[2015-07-15 09:42] [ALPM] installed gdata-sharp (1.7.0.1-3)
[2015-07-15 09:42] [ALPM] installed taglib-sharp (2.1.0.0-2)
[2015-07-15 09:42] [ALPM] installed gudev-sharp (0.1-3)
[2015-07-15 09:42] [ALPM] installed gkeyfile-sharp (0.1-3)
[2015-07-15 09:42] [ALPM] installed gconf-sharp (2.24.2-4)
[2015-07-15 09:42] [ALPM] installed mono-zeroconf (0.9.0-4)
[2015-07-15 09:42] [ALPM] installed mono-upnp (0.1.2-2)
[2015-07-15 09:42] [ALPM] installed gvfs (1.24.1-2)
[2015-07-15 09:42] [ALPM] installed banshee (2.6.2-7)
[2015-07-15 09:42] [ALPM] transaction completed
[2015-08-04 14:42] [PACMAN] Running 'pacman -S jdk8-openjdk'
[2015-08-04 14:42] [PACMAN] Running 'pacman -Syu'
[2015-08-04 14:42] [PACMAN] synchronizing package lists
[2015-08-04 14:42] [PACMAN] starting full system upgrade
[2015-08-04 14:44] [ALPM] transaction started
[2015-08-04 14:44] [ALPM] removed eclipse (4.4.2-1)
[2015-08-04 14:44] [ALPM] upgraded gcc-libs (5.1.0-5 -> 5.2.0-1)
[2015-08-04 14:44] [ALPM] upgraded sqlite (3.8.10.2-1 -> 3.8.11.1-1)
[2015-08-04 14:44] [ALPM] upgraded libdbus (1.8.18-1 -> 1.8.20-1)
[2015-08-04 14:44] [ALPM] upgraded dbus (1.8.18-1 -> 1.8.20-1)
[2015-08-04 14:44] [ALPM] upgraded libsystemd (221-2 -> 224-1)
[2015-08-04 14:44] [ALPM] upgraded systemd (221-2 -> 224-1)
[2015-08-04 14:45] [ALPM] upgraded llvm-libs (3.6.1-1 -> 3.6.2-2)
[2015-08-04 14:45] [ALPM] upgraded mesa (10.6.2-1 -> 10.6.3-1)
[2015-08-04 14:45] [ALPM] upgraded mesa-libgl (10.6.2-1 -> 10.6.3-1)
[2015-08-04 14:45] [ALPM] upgraded hicolor-icon-theme (0.13-1 -> 0.15-1)
[2015-08-04 14:45] [ALPM] upgraded harfbuzz (0.9.41-1 -> 1.0.1-1)
[2015-08-04 14:45] [ALPM] upgraded qt4 (4.8.7-1 -> 4.8.7-2)
[2015-08-04 14:45] [ALPM] upgraded akonadi (1.13.0-4 -> 1.13.0-6)
[2015-08-04 14:45] [ALPM] upgraded gnutls (3.4.2-1 -> 3.4.3-1)
[2015-08-04 14:45] [ALPM] installed libsoxr (0.1.1-3)
[2015-08-04 14:45] [ALPM] upgraded libssh (0.7.0-2 -> 0.7.1-1)
[2015-08-04 14:45] [ALPM] upgraded libx264 (2:144.20150223-1 -> 2:148.20150725-1)
[2015-08-04 14:45] [ALPM] upgraded ffmpeg (1:2.7.1-1 -> 1:2.7.2-2)
[2015-08-04 14:45] [ALPM] upgraded exiv2 (0.24-1 -> 0.25-1)
[2015-08-04 14:45] [ALPM] upgraded strigi (0.7.8-6 -> 0.7.8-7)
[2015-08-04 14:45] [ALPM] upgraded libdatrie (0.2.8-1 -> 0.2.9-1)
[2015-08-04 14:45] [ALPM] upgraded libthai (0.1.21-1 -> 0.1.22-1)
[2015-08-04 14:45] [ALPM] upgraded kfilemetadata4 (4.14.3-1 -> 4.14.3-2)
[2015-08-04 14:45] [ALPM] upgraded mpfr (3.1.3-1 -> 3.1.3.p4-1)
[2015-08-04 14:45] [ALPM] upgraded baloo4-widgets (4.14.3-1 -> 4.14.3-2)
[2015-08-04 14:45] [ALPM] upgraded binutils (2.25-5 -> 2.25.1-1)
[2015-08-04 14:45] [ALPM] upgraded cabextract (1.4-3 -> 1.6-1)
[2015-08-04 14:45] [ALPM] upgraded cairomm (1.10.0-3 -> 1.11.2-1)
[2015-08-04 14:45] [ALPM] upgraded ceph (0.94.2-1 -> 0.94.2-2)
[2015-08-04 14:45] [ALPM] upgraded cmake (3.2.3-1 -> 3.3.0-1)
[2015-08-04 14:45] [ALPM] upgraded colord (1.2.9-3 -> 1.2.11-1)
[2015-08-04 14:45] [ALPM] upgraded libcups (2.0.3-1 -> 2.0.4-1)
[2015-08-04 14:45] [ALPM] upgraded cups (2.0.3-1 -> 2.0.4-1)
[2015-08-04 14:45] [ALPM] upgraded device-mapper (2.02.123-1 -> 2.02.125-1)
[2015-08-04 14:45] [ALPM] upgraded dhcpcd (6.9.0-1 -> 6.9.1-1)
[2015-08-04 14:45] [ALPM] upgraded jre7-openjdk-headless (7.u79_2.5.5-1 -> 7.u85_2.6.1-1)
[2015-08-04 14:45] [ALPM] upgraded jre7-openjdk (7.u79_2.5.5-1 -> 7.u85_2.6.1-1)
[2015-08-04 14:45] [ALPM] upgraded jdk7-openjdk (7.u79_2.5.5-1 -> 7.u85_2.6.1-1)
[2015-08-04 14:45] [ALPM] upgraded libsecret (0.18.2-1 -> 0.18.3-1)
[2015-08-04 14:45] [ALPM] upgraded harfbuzz-icu (0.9.41-1 -> 1.0.1-1)
[2015-08-04 14:45] [ALPM] upgraded libepoxy (1.2-2 -> 1.3.1-1)
[2015-08-04 14:45] [ALPM] upgraded gdk-pixbuf2 (2.31.4-1 -> 2.31.5-1)
[2015-08-04 14:45] [ALPM] upgraded gtk-update-icon-cache (3.16.5-1 -> 3.16.6-1)
[2015-08-04 14:45] [ALPM] upgraded gtk3 (3.16.5-1 -> 3.16.6-1)
[2015-08-04 14:45] [ALPM] upgraded libmm-glib (1.4.8-2 -> 1.4.10-2)
[2015-08-04 14:45] [ALPM] upgraded libnm-glib (1.0.2-4 -> 1.0.4-1)
[2015-08-04 14:45] [ALPM] installed webkitgtk (2.4.9-1)
[2015-08-04 14:45] [ALPM] installed eclipse-common (4.5.0-3)
[2015-08-04 14:45] [ALPM] installed eclipse-java (4.5.0-3)
[2015-08-04 14:45] [ALPM] upgraded file (5.23-2 -> 5.24-1)
[2015-08-04 14:45] [ALPM] upgraded firefox-adblock-plus (2.6.8-1 -> 2.6.9-1)
[2015-08-04 14:45] [ALPM] upgraded flashplugin (11.2.202.481-1 -> 11.2.202.491-1)
[2015-08-04 14:45] [ALPM] upgraded gcc (5.1.0-5 -> 5.2.0-1)
[2015-08-04 14:45] [ALPM] upgraded git (2.4.5-1 -> 2.5.0-1)
[2015-08-04 14:45] [ALPM] upgraded gst-plugins-ugly (1.4.5-2 -> 1.4.5-3)
[2015-08-04 14:45] [ALPM] upgraded gstreamer0.10-ugly (0.10.19-14 -> 0.10.19-15)
[2015-08-04 14:45] [ALPM] upgraded gstreamer0.10-ugly-plugins (0.10.19-14 -> 0.10.19-15)
[2015-08-04 14:45] [ALPM] upgraded libinput (0.19.0-1 -> 0.21.0-1)
[2015-08-04 14:45] [ALPM] upgraded kfilemetadata (5.9.2-1 -> 5.9.2-2)
[2015-08-04 14:45] [ALPM] upgraded kdeclarative (5.12.0-1 -> 5.12.0-2)
[2015-08-04 14:45] [ALPM] upgraded gwenview (15.04.3-1 -> 15.04.3-2)
[2015-08-04 14:45] [ALPM] upgraded libtool (2.4.6-2 -> 2.4.6-3)
[2015-08-04 14:45] [ALPM] upgraded talloc (2.1.2-1 -> 2.1.3-1)
[2015-08-04 14:45] [ALPM] upgraded kdebase-runtime (15.04.3-3 -> 15.04.3-4)
[2015-08-04 14:45] [ALPM] upgraded lib32-libldap (2.4.40-1 -> 2.4.41-1)
[2015-08-04 14:45] [ALPM] upgraded lib32-curl (7.42.1-1 -> 7.43.0-1)
[2015-08-04 14:45] [ALPM] upgraded lib32-gcc-libs (5.1.0-5 -> 5.2.0-1)
[2015-08-04 14:45] [ALPM] upgraded lib32-gnutls (3.4.2-1 -> 3.4.3-1)
[2015-08-04 14:45] [ALPM] upgraded lib32-libdbus (1.8.18-1 -> 1.8.20-1)
[2015-08-04 14:45] [ALPM] upgraded lib32-libtiff (4.0.3-3 -> 4.0.4-1)
[2015-08-04 14:45] [ALPM] upgraded lib32-llvm-libs (3.6.1-1 -> 3.6.2-1)
[2015-08-04 14:45] [ALPM] upgraded lib32-systemd (221-1 -> 224-1)
[2015-08-04 14:45] [ALPM] upgraded lib32-mesa (10.6.2-1 -> 10.6.3-1)
[2015-08-04 14:45] [ALPM] upgraded lib32-mesa-libgl (10.6.2-1 -> 10.6.3-1)
[2015-08-04 14:45] [ALPM] upgraded lib32-sqlite (3.8.10.2-1 -> 3.8.11.1-1)
[2015-08-04 14:45] [ALPM] upgraded libgphoto2 (2.5.7-1 -> 2.5.8-1)
[2015-08-04 14:45] [ALPM] upgraded libkexiv2 (15.04.3-1 -> 15.04.3-2)
[2015-08-04 14:45] [ALPM] upgraded libkolabxml (1.1.0-2 -> 1.1.1-1)
[2015-08-04 14:45] [ALPM] upgraded libnice (0.1.10-1 -> 0.1.13-1)
[2015-08-04 14:45] [ALPM] upgraded libteam (1.14-2 -> 1.17-1)
[2015-08-04 14:45] [ALPM] upgraded libunistring (0.9.5-1 -> 0.9.6-1)
[2015-08-04 14:45] [ALPM] warning: directory permissions differ on /var/lib/libvirt/qemu/
filesystem: 755  package: 770
[2015-08-04 14:45] [ALPM] upgraded libvirt (1.2.17-1 -> 1.2.18-1)
[2015-08-04 14:45] [ALPM-SCRIPTLET] >>> You may need to run 'rm -rf ~/.libvirt'
[2015-08-04 14:45] [ALPM] upgraded linux-firmware (20150527.3161bfa-1 -> 20150722.e10097a-1)
[2015-08-04 14:45] [ALPM] upgraded linux (4.0.7-2 -> 4.1.4-1)
[2015-08-04 14:45] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2015-08-04 14:45] [ALPM-SCRIPTLET] >>> Generating initial ramdisk, using mkinitcpio.  Please wait...
[2015-08-04 14:45] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2015-08-04 14:45] [ALPM-SCRIPTLET] ==> Starting build: 4.1.4-1-ARCH
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2015-08-04 14:45] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2015-08-04 14:45] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2015-08-04 14:45] [ALPM-SCRIPTLET] ==> Image generation successful
[2015-08-04 14:45] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2015-08-04 14:45] [ALPM-SCRIPTLET] ==> Starting build: 4.1.4-1-ARCH
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2015-08-04 14:45] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2015-08-04 14:45] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2015-08-04 14:45] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2015-08-04 14:45] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2015-08-04 14:45] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2015-08-04 14:45] [ALPM-SCRIPTLET] ==> Image generation successful
[2015-08-04 14:45] [ALPM] upgraded linux-headers (4.0.7-2 -> 4.1.4-1)
[2015-08-04 14:45] [ALPM] upgraded lvm2 (2.02.123-1 -> 2.02.125-1)
[2015-08-04 14:46] [ALPM] upgraded man-pages (4.00-1 -> 4.01-1)
[2015-08-04 14:46] [ALPM] upgraded maven (3.3.3-1 -> 3.3.3-2)
[2015-08-04 14:46] [ALPM] upgraded mercurial (3.4.2-1 -> 3.5-1)
[2015-08-04 14:46] [ALPM] upgraded mplayer (37379-3 -> 37379-4)
[2015-08-04 14:46] [ALPM] upgraded netctl (1.10-2 -> 1.11-1)
[2015-08-04 14:46] [ALPM] upgraded networkmanager (1.0.2-4 -> 1.0.4-1)
[2015-08-04 14:46] [ALPM] warning: directory permissions differ on /usr/lib/node_modules/npm/node_modules/.bin/
filesystem: 777  package: 755
[2015-08-04 14:46] [ALPM] upgraded npm (2.13.0-1 -> 2.13.2-1)
[2015-08-04 14:46] [ALPM] upgraded openjdk7-doc (7.u79_2.5.5-1 -> 7.u85_2.6.1-1)
[2015-08-04 14:46] [ALPM] upgraded openjdk7-src (7.u79_2.5.5-1 -> 7.u85_2.6.1-1)
[2015-08-04 14:46] [ALPM] upgraded openjdk8-doc (8.u45-1 -> 8.u51-1)
[2015-08-04 14:46] [ALPM] upgraded openjdk8-src (8.u45-1 -> 8.u51-1)
[2015-08-04 14:46] [ALPM] upgraded openssh (6.9p1-1 -> 6.9p1-2)
[2015-08-04 14:46] [ALPM] warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
[2015-08-04 14:46] [ALPM] upgraded pacman-mirrorlist (20150713-1 -> 20150731-1)
[2015-08-04 14:46] [ALPM] upgraded pacman (4.2.1-1 -> 4.2.1-2)
[2015-08-04 14:46] [ALPM] upgraded perl-dbi (1.633-2 -> 1.634-1)
[2015-08-04 14:46] [ALPM] upgraded perl-uri (1.68-1 -> 1.69-1)
[2015-08-04 14:46] [ALPM] upgraded perl-http-message (6.08-1 -> 6.10-1)
[2015-08-04 14:46] [ALPM] upgraded sip (4.16.8-1 -> 4.16.9-1)
[2015-08-04 14:46] [ALPM] upgraded python2-sip (4.16.8-1 -> 4.16.9-1)
[2015-08-04 14:46] [ALPM] upgraded qjackctl (0.3.13-1 -> 0.4.0-2)
[2015-08-04 14:46] [ALPM] upgraded speech-dispatcher (0.8.3-2 -> 0.8.3-5)
[2015-08-04 14:46] [ALPM] warning: /etc/sudoers installed as /etc/sudoers.pacnew
[2015-08-04 14:46] [ALPM] upgraded sudo (1.8.13-1 -> 1.8.14.p3-2)
[2015-08-04 14:46] [ALPM] upgraded systemd-sysvcompat (221-2 -> 224-1)
[2015-08-04 14:46] [ALPM] upgraded virtualbox-host-modules (4.3.28-2 -> 5.0.0-2)
[2015-08-04 14:46] [ALPM-SCRIPTLET] In order to use the new version, reload all virtualbox modules manually.
[2015-08-04 14:46] [ALPM] upgraded virtualbox (4.3.28-1 -> 5.0.0-1)
[2015-08-04 14:46] [ALPM-SCRIPTLET] 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
[2015-08-04 14:46] [ALPM] upgraded virtualbox-ext-vnc (4.3.28-1 -> 5.0.0-1)
[2015-08-04 14:46] [ALPM-SCRIPTLET] 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
[2015-08-04 14:46] [ALPM] upgraded virtualbox-guest-iso (4.3.28-1 -> 5.0.0-1)
[2015-08-04 14:46] [ALPM] upgraded virtualbox-guest-modules (4.3.28-2 -> 5.0.0-2)
[2015-08-04 14:46] [ALPM] upgraded xorg-server-common (1.17.2-2 -> 1.17.2-4)
[2015-08-04 14:46] [ALPM] upgraded xorg-server (1.17.2-2 -> 1.17.2-4)
[2015-08-04 14:46] [ALPM] upgraded virtualbox-guest-utils (4.3.28-1 -> 5.0.0-1)
[2015-08-04 14:46] [ALPM] upgraded wine (1.7.47-1 -> 1.7.48-1)
[2015-08-04 14:46] [ALPM] installed l-smash (2.3.0-2)
[2015-08-04 14:46] [ALPM] upgraded x264 (2:144.20150223-1 -> 2:148.20150725-1)
[2015-08-04 14:46] [ALPM] upgraded xf86-video-intel (1:2.99.917+364+gb24e758-1 -> 1:2.99.917+381+g5772556-1)
[2015-08-04 14:46] [ALPM] transaction completed

Console-Output:

[sebastian@ulbp2681 ~]$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 4c:72:b9:4b:08:09 brd ff:ff:ff:ff:ff:ff
    inet 141.35.23.78/22 brd 141.35.23.255 scope global enp2s0
       valid_lft forever preferred_lft forever
    inet6 fe80::856b:fd54:837f:38d/64 scope link
       valid_lft forever preferred_lft forever
[sebastian@ulbp2681 ~]$ ip route
default via 141.35.20.1 dev enp2s0  metric 202
141.35.20.0/22 dev enp2s0  proto kernel  scope link  src 141.35.23.78  metric 202
[sebastian@ulbp2681 ~]$ journalctl -b _SYSTEMD_UNIT=NetworkManager.service
-- No entries --

after I was checking my syslog I fpund that:

Aug 06 06:45:23 ulbp2681 kernel: alx 0000:02:00.0 enp2s0: fatal interrupt 0x400, resetting
Aug 06 06:45:23 ulbp2681 kernel: alx 0000:02:00.0 enp2s0: NIC Up: 1 Gbps Full
Aug 06 06:45:23 ulbp2681 dhcpcd[1226]: enp2s0: carrier lost
Aug 06 06:45:23 ulbp2681 dhcpcd[1226]: enp2s0: deleting default route via 141.35.20.1
Aug 06 06:45:23 ulbp2681 avahi-daemon[455]: Withdrawing address record for 141.35.23.78 on enp2s0.
Aug 06 06:45:23 ulbp2681 avahi-daemon[455]: Leaving mDNS multicast group on interface enp2s0.IPv4 with address 141.35.23.78.
Aug 06 06:45:23 ulbp2681 avahi-daemon[455]: Interface enp2s0.IPv4 no longer relevant for mDNS.
Aug 06 06:45:23 ulbp2681 dhcpcd[1226]: enp2s0: carrier acquired
Aug 06 06:45:23 ulbp2681 dhcpcd[1226]: enp2s0: rebinding lease of 141.35.23.78
Aug 06 06:45:25 ulbp2681 ntpd[491]: Deleting interface #84 enp2s0, 141.35.23.78#123, interface stats: received=4, sent=36, dropped=0, active_time=713 secs
Aug 06 06:45:25 ulbp2681 ntpd[491]: 5.9.159.253 local addr 141.35.23.78 -> <null>
Aug 06 06:45:25 ulbp2681 ntpd[491]: 144.76.96.7 local addr 141.35.23.78 -> <null>
Aug 06 06:45:25 ulbp2681 ntpd[491]: 129.70.132.35 local addr 141.35.23.78 -> <null>
Aug 06 06:45:25 ulbp2681 ntpd[491]: 85.10.246.226 local addr 141.35.23.78 -> <null>
Aug 06 06:45:29 ulbp2681 dhcpcd[1226]: enp2s0: leased 141.35.23.78 for 691200 seconds
Aug 06 06:45:29 ulbp2681 avahi-daemon[455]: Joining mDNS multicast group on interface enp2s0.IPv4 with address 141.35.23.78.
Aug 06 06:45:29 ulbp2681 dhcpcd[1226]: enp2s0: adding route to 141.35.20.0/22
Aug 06 06:45:29 ulbp2681 avahi-daemon[455]: New relevant interface enp2s0.IPv4 for mDNS.
Aug 06 06:45:29 ulbp2681 dhcpcd[1226]: enp2s0: adding default route via 141.35.20.1
Aug 06 06:45:29 ulbp2681 avahi-daemon[455]: Registering new address record for 141.35.23.78 on enp2s0.IPv4.
Aug 06 06:45:29 ulbp2681 NetworkManager[453]: <info>  Policy set 'enp2s0' (enp2s0) as default for IPv4 routing and DNS.
Aug 06 06:45:29 ulbp2681 dhcpcd[1226]: enp2s0: removing route to 141.35.20.0/22
Aug 06 06:45:31 ulbp2681 ntpd[491]: Listen normally on 85 enp2s0 141.35.23.78:123
Aug 06 06:45:31 ulbp2681 ntpd[491]: new interface(s) found: waking up resolver
Aug 06 06:55:47 ulbp2681 kernel: alx 0000:02:00.0 enp2s0: fatal interrupt 0x400, resetting
Aug 06 06:55:47 ulbp2681 kernel: alx 0000:02:00.0 enp2s0: NIC Up: 1 Gbps Full
....

SO how could I solve this bug in the kernel? I tried a rollback to the pivious kernel, but this didn't work eather maybe I did it wrong?

  • Check your dns configuration – neuron Aug 5 '15 at 5:43
  • How do you manage your network connection? What is in the journal? What was updated? More information is needed... – jasonwryan Aug 5 '15 at 5:51
  • I added some Information – Sebastian Röher Aug 5 '15 at 6:06
  • Can you please post the section of pacman.log (By default /var/log/pacman.log) corresponding to the update procedure from yesterday? I expect this will be a very long file since you hadn't updated in several months. Also post the last line of the previous update so that we can tell when it took place (for relevant update informations during that time period). – Emeric Aug 5 '15 at 7:23
  • I added the log – Sebastian Röher Aug 5 '15 at 7:51
2

It seems to be a bug the kernel.

After rollback and downgrade of all updated network packages it works again

this was the command i used:

[root@ulbp2681 ~]# cd /var/cache/pacman/pkg
[root@ulbp2681 pkg]# pacman -U linux-4.0.7-2-x86_64.pkg.tar.xz linux-headers-4.0.7-2-x86_64.pkg.tar.xz dhcpcd-6.9.0-1-x86_64.pkg.tar.xz netctl-1.10-2-any.pkg.tar.xz networkmanager-1.0.2-4-x86_64.pkg.tar.xz

2 things I needed to find the solution:

  1. journalsctl -b for systemlog after current boot
  2. pacman-logfiles to see what has been updated

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.