2

So my onboard sound-card died and I bought a new small usb one.

With windows it works perfectly, but on my debian testing not so much.

It isn't detected by my audio system, and I cannot choose the device in the alsamixer application.

Which component of my system handles the soundcard-detection and where should I look for the answer?

$ [23:40:17] simon@tuna :~
> lspci -v | grep Audio
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV770 HDMI Audio [Radeon HD 4850/4870]
$ [23:41:48] simon@tuna :~
> lsusb | grep Audio
Bus 003 Device 002: ID 0d8c:000c C-Media Electronics, Inc. Audio Adapter
$ [23:41:51] simon@tuna :~
> cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfe8fc000 irq 46
 2 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfe7f8000 irq 45
$ [23:42:14] simon@tuna :~
> uname -r
3.16.0-4-amd64

regards

edit:

$ [00:14:03] simon@tuna :~
> cat /proc/asound/modules 
 0 snd_hda_intel
 2 snd_hda_intel
$ [00:22:33] simon@tuna :~
> lsmod | grep snd
snd_usb_audio         135354  0 
snd_usbmidi_lib        23388  1 snd_usb_audio
snd_rawmidi            26806  1 snd_usbmidi_lib
snd_seq_device         13132  1 snd_rawmidi
snd_hda_codec_realtek    67127  1 
snd_hda_codec_generic    63181  1 snd_hda_codec_realtek
snd_hda_codec_hdmi     45118  1 
snd_hda_intel          26327  2 
snd_hda_controller     26646  1 snd_hda_intel
snd_hda_codec         104463  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              13148  2 snd_usb_audio,snd_hda_codec
snd_pcm                88662  5 snd_usb_audio,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_timer              26614  1 snd_pcm
snd                    65244  16 snd_hda_codec_realtek,snd_usb_audio,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_rawmidi,snd_hda_codec_generic,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device
soundcore              13026  2 snd,snd_hda_codec
usbcore               195340  6 uhci_hcd,snd_usb_audio,snd_usbmidi_lib,ehci_hcd,ehci_pci,usbhid
$ [00:24:34] simon@tuna :~
> cat /etc/modprobe.d/alsa-base.conf 
options snd_hda_intel index=1
options snd_hda_intel index=2
options snd_usb_audio index=0

edit2:

$ [22:18:13] simon@tuna :~
> lsusb
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 046d:c041 Logitech, Inc. G5 Laser Mouse
Bus 004 Device 002: ID 046a:0021 Cherry GmbH CyMotion Expert Combo
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 003: ID 18d1:4e22 Google Inc. Nexus S (debug)
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 0d8c:000c C-Media Electronics, Inc. Audio Adapter
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


EDIT solved:

After I blacklisted snd-hda-intel and rebooted everything worked perfectly out of the box...

4
  • 1
    /etc/modprobe.d/alsa-base.conf - replace "options snd-usb-audio index=-2" with "options snd-usb-audio index=0" and reboot ? If still no luck, add "lsmod | grep snd" to question.
    – steve
    Commented Aug 4, 2015 at 22:16
  • 1
    my alsa-base.conf was already set to this (I believe from an earlier attempt on the problem). Added the suggested IInformatoin to the question.
    – Simon Lenz
    Commented Aug 4, 2015 at 22:26
  • 1
    The output of lsusb would be helpful here too.
    – eyoung100
    Commented Aug 4, 2015 at 23:19
  • 1
    I've added a complete lsusb to the question
    – Simon Lenz
    Commented Aug 5, 2015 at 20:20

2 Answers 2

2
> cat /etc/modprobe.d/alsa-base.conf 
options snd_hda_intel index=1
options snd_hda_intel index=2
options snd_usb_audio index=0

There can be only a single options line for one module, so snd-hda-intel ends up with the option index=2.

Options with multiple values must use a single line, with the values separated by commas (index=1,2).

However, for this case, it would be much easier to use the slots option instead:

options snd slots=snd-usb-audio,snd-hda-intel,snd-hda-intel
2

After I blacklisted snd-hda-intel and rebooted everything worked perfectly out of the box.

2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .