1

I am running Debian 8 on a Toshiba Satellite laptop. When at home I connect my laptop to an external monitor through an HDMI cable.

My laptop's monitor has recently stopped supporting any display mode except for 640x480. Here's the output of xrandr:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
LVDS1 connected (normal left inverted right x axis y axis)
   640x480       59.94  
VGA2 disconnected (normal left inverted right x axis y axis)
HDMI1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 600mm x 340mm

   1920x1080     60.00*+  50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
   1680x1050     59.88  
   1400x1050     59.95  
   1600x900      59.98  
   1280x1024     60.02  
   1440x900      59.90  
   1280x800      59.91  
   1152x864      59.97  
   1280x720      60.00    50.00    59.94  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       60.00    59.94  
DP1 disconnected (normal left inverted right x axis y axis)

As you can see, the only mode available for my laptop's monitor is 640x480, even though it usually supports many modes up to 1366x768.

This is not a hardware problem because my GRUB menu uses 1366x768 just fine.

I think the problem started after I messed with my graphics card settings. I was trying to get Debian to use my NVIDIA graphics card so I ran the command nvidia-xconfig. The X Window System would not resume on startup however (probably because I do not have the required packages to use my NVIDIA graphics card), so I modified /etc/X11/xorg.conf so that x-org would use my Intel graphics card instead.

I believe that ever since my laptop's monitor has stopped supporting higher resolution display modes.

1

It turns out that deleting /etc/X11/xorg.conf solved my problems.

  • 1
    Please use the edit link on your question to add additional information. The Post Answer button should be used only for complete answers to the question. – Drav Sloan Aug 4 '15 at 20:33
  • Why does this not qualify as a complete answer? – Alessandro Power Aug 4 '15 at 22:18
  • In your instance it may have solved the issue, but in many cases deleting this file could cause more problems that it could fix for others. It would be better put as an edit to your original question (so that a more specific in depth solution could be offered by others). – Drav Sloan Aug 4 '15 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.