Mouse can't work on Ubuntu Server (minmal virtual machine mode) in VBox VM. I ran:

sudo aptitude install --without-recommends xserver-xorg-core
sudo aptitude install jwm


-bash: startx: command not found.

Update: OK, xinit was missing.

Update 2: So I ran:

sudo aptitude --without-recommends install xinit  

installation ok, then:



/etc/X11/xinit/xserverrc: 3: exec: /usr/bin/X: not found
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

Update 3: Some package were left out! So I purged all before mentioned and reinstalled all three except no --without-recommends flag this time.
Apparently I can access the simple graphical desktop but with problems. Mouse won't move. Output from tty; can't roll up, it has cancel at this point (or has it ended outputing?)

loading extension GLX
The XKEYBOARD keymap compiler (xkbcomp) reports:
Warning: Type "ONE_LEVEL" has 1 levels, but has 2 symbols
Ignoring extra symbols
Erros from xkbcomp are not fatal to the X server

Update 4: Installed guest additions and begins to master the game.

Thanks for your time.

  • 2
    You also need sudo apt-get install xinit for /usr/bin/startx. – yaegashi Aug 4 '15 at 5:33
  • well done, but I would like hit for essential. I read question link and realized they are xinits' fork. If I follow it up xserver-xorg-input-all xserver-xorg-video-fbdev xserver-xorg-video-intel, as my video chipset is intel, would it handle the basic graphic output (in place of xinit)? – Mecah Aug 6 '15 at 1:50
  • Sorry I cannot get what you want to ask exactly. You might as well edit your post or open a new question to describe details clearly. – yaegashi Aug 6 '15 at 2:17
  • Have you looked for X in /usr/bin/? Also look in /etc/X11/. If you have it in/etc/X11/ you could try to link it in /usr/bin, but I'm not certain if this will work. Or try sudo apt-get install --no-install-recommends xserver-xorg-core xserver-xorg-input-all xserver-xorg-video-fbdev – Spilt_Blood Aug 13 '15 at 3:39
  • sorry, actually the output is for startx. how do I link it ? – Mecah Aug 13 '15 at 4:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.