I installed the mini ISO of Ubuntu 11.04 in VirtualBox. After unmounting the ISO image and booting, I can see only black screen for about two hours? Is it normal? What can I do with it in virtual box and proceed with running the system successfully?

thank you

  • 2
    See this answer to debug your problem. When you start the virtual machine and the bootloader loads, press Shift, then e to modify the options, remove quiet and splash (or add nosplash at the end). – rozcietrzewiacz Oct 8 '11 at 15:34
  • I tried it, it stuck after virtual machine additions so I installed it but after installation Shift does not work to make it more verbose. I'm looking at logs but I don't understand where could be the fault. – xralf Oct 12 '11 at 12:24
  • You mean you installed VirtualBox Guest Additions using an iso image? You probably need to remove it from the configuration of the machine now - it may be trying to boot from that image instead of Ubuntu. What logs are you writing about? What do they contain? Don't you think they can be helpful? – rozcietrzewiacz Oct 12 '11 at 12:55
  • Yes, I installed VirtualBox Guest Additions using apt-get. Which configuration do you mean? Here is one of the logs. – xralf Oct 12 '11 at 15:26

The VirtualBox log that you posted indicates that your installation (the guest Ubuntu system on virtual disk) is broken - notice all the BIOS: Boot-like messages - the machine tries to boot, but fails over and over again. The system probably does not boot at all or fails early - it is hard to tell just from the VirtualBox logs. If possible, try to reinstall this virtual system.

  • I already tried it but had problems with reinstalling. I downloaded deb packages and reinstallation didn't help. I installed the old packages again. But now I have stuck and can't remove nor install with apt. If you're good at installing, I can send you output of everything to pastebin. – xralf Oct 14 '11 at 9:49
  • Hold on - what you mean with "downloaded deb packages" or using apt? What are/were you reinstalling? VirtualBox? You should re-install the virtual Ubuntu machine, not the VirtualBox application. – rozcietrzewiacz Oct 14 '11 at 10:02
  • Yes, OK, I will try to reinstall it, but it takes (I guess) about two hours. – xralf Oct 14 '11 at 11:35
  • Yes, something about that. Otherwise, you might create a new virtual machine with a separate virtual disk. And make sure, while setting it up, to choose appropriate settings (like system type: Ubuntu). – rozcietrzewiacz Oct 14 '11 at 11:42
  • I reinstalled the virtual machine. After reboot I have chosen boot device with F12, I press 1 because I want to boot from harddrive, nothing happens, when I hold shift, the menu (where I can delete quiet and splash) won't appear – xralf Oct 14 '11 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.