0

I have a strange problem with terminal settings. I am a Debian 3.16.7 user. I saw the .bashrc file using ls -a but I couldn't open it (no file comunicate), so I restored it from /etc/skel/.bashrc.

Now my .bashrc file looks ok but I can't source it. For example when I call echo $HISTSIZE I see 30 but in my .bashrc I have got 1000.

Here is how my .bashrc file looks: http://pastebin.com/cYMY6rJj

after

 ls -a

I see:

toshiba% ls -a
.          .gnome2      .themes
..         .gnome2_private  .thumbnails
.adobe         .gnupg       .tmux
.bash_history  .gstreamer-0.10  .tmux.conf
.bash_logout   .gtk-bookmarks   .tmuxinator
.bashrc        .ICEauthority    Videos
.bat           .icons       .vim
.bin           .java        .vim-colortuner
.cache         jbus_client  .vim-cscope
.cgdb          .kde     .vim-fuf-data
.config        .local       .viminfo
.cscope.vim    .macromedia  .vimrc
.dbus          .mozilla     .vim-sessions
Desktop        Music        .vim-undo
.dircolors     .osd_conf    .w3m
Documents      Pictures     .wireshark
Downloads      .pip     workspace
.easystroke    .pki     .xfce4-session.verbose-log
eclipse        .profile     .xfce4-session.verbose-log.last
.face          Public       .zcache
.fonts         .PyCharm40   .zsh
.gconf         PycharmProjects  .zsh_compdump
.gdb           .recently-used   .zsh_history
.gitconfig     .ssh     .zshrc
.gksu.lock     .subversion
.gnome         Templates

My .profile file is empty. Please help.

  • It looks as if your shell is zsh not bash. What is the results of echo $SHELL? – fd0 Aug 3 '15 at 10:44
0

You are probably running into the difference between login and non-login instances of bash. If bash is started as a login shell, it reads .bash_profile. If it is not started as a login shell, it reads .bashrc. You can easily check if this is the problem by starting another instance of bash from the command line (that is, just type bash and hit return) and see if your .bashrc settings take effect.

This is described in detail under the heading INVOCATION in the bash manual page.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.