2

I need to disable my laptop's keyboard so that keyboard can only be used via USB. I am not using X, I am on the Linux console. The solution should be able to start as early in the boot process as possible, as the problem with my internal keyboard often affects inputting the password to my encrypted partition.

2

This is kind of crude, but why not just blacklist the atkbd driver.

echo blacklist atkbd > /etc/modprobe.d/no-atkbd.conf

You'll probably need to rebuild your initrd to make sure it gets blacklisted very early on in the boot process.

4
  • How can I know if I did this correctly? It has not disabled the keyboard. – Ronald Snew Aug 3 '15 at 6:28
  • If you run lsmod, do you see atkbd in the list of modules? Also, you can explicitly remove it with rmmod atkbd to see if this solution even works. It could be that your OS distro just always loads this module, or that it compiles it into the kernel instead of as a module. – user3188445 Aug 3 '15 at 16:56
  • This also disables the USB keyboard. – Ronald Snew Aug 3 '15 at 20:53
  • 1
    Ah, bummer. What about loading the i8042 module with nokbd=1, or booting with i8042.nokbd=1? – user3188445 Aug 3 '15 at 21:33
-1

Run the command in the terminal:

xinput list

It get you list of devices. Than you can disable some of them by id:

xinput set-prop 10 "Device Enabled" 0
1
  • 4
    OP is not using X. – don_crissti Aug 2 '15 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.