2

Whenever i start a 32-bit program aka. 386 with primusrun on debian jessie (be it steam or any of it's 32-bit games), i get a following error:

wv@localhost:~$ primusrun steam
Running Steam on debian 8 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1437790054)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

I have bumblebee-nvidia, primus, primus-libs and primus-libs:i386 installed. Swrast driver is present in /usr/lib/i386-linux-gnu/dri/ directory. Both 32 and 64 bit libGL.so.1* are present in the system. What could be wrong here? Has anybody met and successfully resolved a similar problem? 64 bit games run through steam work fine (using launch options primusrun %command%). This occures to 32 bit games only.

0

Finally i've found the solution. Something's completely wrong with all those multiple libGL.so.1 lib files around the system. So solution for this is performing next commands as root:

apt-get purge bumblebee bumblebee-nvidia primus primus-libs primus-libs:i386
apt-get purge glx-diversions
apt-get purge libgl1-mesa-glx:i386
apt-get autoremove

Wait some time until everything is deleted (this might also delete skype and/or some other 32-bit programs if they depend on 32-bit libgl1-mesa-glx, don't worry, it's easy to restore them. In my case it was only skype)

apt-get update
apt-get install bumblebee-nvidia primus primus-libs primus-libs:i386 libgl1-mesa-glx:i386

All the symlinks are recreated, all libraries' versions are correct, and everything works as intended.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.